Harlan
This release includes the biggest speed optimization we have done yet and significant reliability improvements. Plus, there are several fixes to the UI of the tools layout. Highly recommended and worth upgrading if you are using the beta.

Warning: Once you use data in this version of the beta, you will not be able to open it in the previous releases, so back up your data prior to running if you do not want to be permanently in the beta track...

Version 4.1.0.9

September 12, 2007

  • Faster Visualization
    • The layout routines for displaying thoughts have been optimized.
    • Response times are up to 30 times faster when many thoughts are onscreen.
  • Improved Reliability
    • The underlying database that stores PersonalBrain data has been modified to avoid problems that could lead to corruption of the indexes, requiring a rebuild of the database.
    • This change addresses the underlying cause of all reported data corruption issues to date. While these data corruptions are rare and can be recovered in most cases, this update should eliminate them entirely.
  • Tools Layout
    • The feedback mechanism showing where the window will be placed during a drag and drop operation is better, and highlights the target area more clearly.
    • Docking target area of tools windows has been made narrower so that it is easier to merge windows together
    • Fixed: When the PersonalBrain window is set to always on top, drag and drop of tools windows does not show feedback.
  • Linux
    • An archive format without an installer is now available.
  • Fixes
    • Rebuilding of database tables stops after 100 consecutive corrupted rows
    • Java 1.4.2 compatibility has been restored (prior releases of 4.1 required Java 1.5)



Regards,
-Harlan
Quote
jackvinson
How long is the beta expected to run?
Quote
Dryopithecus
Great improvements!!

Best regards,
Yang

Quote
Harlan
jackvinson wrote: How long is the beta expected to run?

Jack, the 4.1 beta will become a release candidate likely in the next 2 to 4 weeks. We will then go to a 4.2 beta cycle.
Regards,
-Harlan
Quote
tcahill
When I clicked on the reports tab and tried to select a report type, a thick fog (i.e., opaque grey ) decended upon the entire plex. PB is still running, as I can sort of access the menu items (sort of because any items extending below the menu border quickly fall below the fog)

OpenSuse 10.2, KDE 3.5, Java 1.6.01

[Edit by TC] I'm relocating this thread over to the Linux Forum as it seems my difficulties are not related to the 4.1.0.9 release, but are particular to something I've mucked up on my PC. I'll post the link to the new thread here... Click image for larger version - Name: all_grey.png, Views: 448, Size: 12.39 KB Click image for larger version - Name: all_grey1.png, Views: 446, Size: 27.52 KB Click image for larger version - Name: all_grey2.png, Views: 443, Size: 15.93 KB
Be vewy quiet. I'm hunting wabbit.
Quote
tcahill
PB 4.1.0.9

Closing and re-opening a PB file does not restore the display, but Closing and re-opening PB itself does.

Once again, attempting to select a report type causes display corruption. This time the bug affects the menu items and the plex remains accessible. Attempting to select menu items cause them to duplicate and jump vertically. Click image for larger version - Name: all_grey3.png, Views: 445, Size: 43.08 KB
Be vewy quiet. I'm hunting wabbit.
Quote
Harlan
Hi Tim,

I'm not able to reproduce the problem you are having. It seems like a resource issue. Can you try running a small report and see if you get the same issue? Maybe try is All dates > Created since.

If this works, let us know. Either way, when it stops working again, please post your output.log file and we'll see what we can discover. Thanks.

Regards,
-Harlan
Quote
tcahill
Harlan wrote: Hi Tim, I'm not able to reproduce the problem you are having. It seems like a resource issue. Can you try running a small report and see if you get the same issue? Maybe try is All dates > Created since. If this works, let us know. Either way, when it stops working again, please post your output.log file and we'll see what we can discover. Thanks.

O.K.

Run Personal Brain 4.1.0.9. Close current brain. Create new brain, called "test". Test has only one thought. Click on "reports" tab. Click on "All" selection arrow. list of available reports begins to display. PB window switches to fog grey. Flickers, Plex recovers, but active thought indicator is not spinning. Top and bottom are greyed out to various extent. (see graphic). Menu items behave erratically. Close PB. Upon re-opening PB, presented with following dialog...

Recovering Brain ID..../OK

Output and error logs attached... Click image for larger version - Name: all_grey4.png, Views: 418, Size: 25.38 KB Click image for larger version - Name: all_grey5.png, Views: 416, Size: 33.49 KB
Be vewy quiet. I'm hunting wabbit.
Quote
Harlan
There was nothing in the log file unfortunately. Based on your description though, it sounds like the problem starts before you even run a report - right when you click the downward arrow in the "All" dropdown. Is that correct?

Can you verify that this problem started on 4.1.0.9?

What OS are you using?

Regards,
-Harlan
Quote
Harlan
Also, does the problem happen if you click a different drop down (All attachments for example)?
Regards,
-Harlan
Quote
tcahill
Harlan wrote: Also, does the problem happen if you click a different drop down (All attachments for example)?

OK. I'll Back up a bit. Something that might be related is that earlier today I was running a Java-based demo of interactivebrokers.ca online trading software. It was the first time that I ran that application; it ran fine and exited properly. I have not logged out since then, so it might be something relating to that Java application that is interfering with PB. So I will run the tests you suggest, then re-boot to see if that clears anything up.

These problems have been occuring on OpenSuse 10.2 on Intel Hardware, KDE 3.5, Java 1.6.01.

Once again, on starting PB, I receive the error message "Message (i in a circle) Recovering Brain ID ...
OK (confirmation button).

Touching the "All dates" selector also causes the blow up. Application is still minimally functioning, but I notice the Title bar now says "null - PersonalBrain4".

I'll post this, re-boot, and see post if the errors persist or not.

Be vewy quiet. I'm hunting wabbit.
Quote
tcahill
So, after re-booting, the problem does persist. This error did not occur prior to 4.1.0.9.

Cheers.
Be vewy quiet. I'm hunting wabbit.
Quote
tcahill
Further problems:

Unable to create events. When I double-click in the events window, a new event appears. I can type text into the event, then I must tab into the date pop-up calendar. However, when I do this, the event disappears.


Oh, Unable to create thoughts. Great. Here is what I hadn't noticed before. When I try to open a brain file that has experienced the crash I've been describing, I noticed that I was getting the "Brain ID" message. I'd been clicking on the message, then working on other non-PB things. However, after clicking on the message, PB indicates "null - PersonalBrain 4 in the Windows Title."

Here is the sequence of the error:

1) Open PB and create a new file (2nd image)
2) Click on Reports tab and try to select a report. Crash. (3rd and 4th images)
3) Close PB and re-start it. "Recovering brain ID" Message while opening previous file. (5th image)
4) File is opened as "null". No further changes to file possible. (top image)

In the next reply I will upload the broken brain file.
Click image for larger version - Name: all_grey6.png, Views: 401, Size: 41.77 KB Click image for larger version - Name: all_grey7.png, Views: 397, Size: 44.46 KB Click image for larger version - Name: all_grey8.png, Views: 395, Size: 23.79 KB Click image for larger version - Name: all_grey9.png, Views: 390, Size: 36.48 KB Click image for larger version - Name: all_grey10.png, Views: 402, Size: 43.65 KB
Be vewy quiet. I'm hunting wabbit.
Quote
tcahill
Trying to make a brainzip of this broken file, but it doesn't seem to completing properly. A creating BrainZip message is appearing with a status indicator moving to the left and right, but it doesn't actually seem to be doing anything and the folder where the brainzip is supposed to be created is still empty.

Meanwhile, here is an archive of the broken file and it's folder that I've created independently of the brainzip process. Click image for larger version - Name: all_grey11.png, Views: 394, Size: 42.13 KB
Be vewy quiet. I'm hunting wabbit.
Quote
tcahill
By the way, the "Creating Brainzip" message is still there... I think I'll force PB to close, as I suspect it is trying to zip a null file. (I'm thinking THAT might take a while.

Problem is yet worse than I'd thought. It seems that I am unable to re-open properly any of the files that I've created, even those that I created and closed before there was a PB crash.

I think I will try to re-install PB 4.1.0.8, and just see where that leaves things....

As expected 4.1.0.8 cannot open any of the files created or accessed with 4.1.0.9. Fine, create a new file. Open Reports tab. Click on a report selector. Crash. Hmmm. Not good.

Let's try 4.1.0.7.... That one can open the file created by 4.1.0.8. Let's see if it is stable.... And it isn't. What is going on?

I'm going to re-boot (seriously. last time I just logged out and re-started the X session)



Be vewy quiet. I'm hunting wabbit.
Quote

Add a Website Forum to your website.

Newsletter Signup  Newsletter Signup        Visit TheBrain Blog   Visit TheBrain Blog       Follow us on Twitter   Follow Us       Like Us on Facebook   Like Us         Circle Us on Google+  Circle Us         Watch Us on Youtube  Watch Us       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software