Kriggel23
Hi,

once again the buttons on top of the list of attachments are not working. The active thought got one single text file attached to it and whether I mark it or not, all buttons are not working, e.g. the delete-button (red cross) does not fire, even visually being active - being a red cross and not grayed out.

A workaround is the context menu of the active thought "Delete attachment".

After having deleted the file this way and attaching a new one via D&D the buttons are still not working.

After activating another thought with a text file attached to it the buttons are still not working.

Kind regards,
Kriggel23


Quote
Harlan
I can't seem to reproduce the problem here... Can you describe in more detail how you are selecting the file? Using the mouse? Arrow keys?

Do the buttons become enabled (non-grey)? When you click the buttons what happens?

Thanks.

Regards,
-Harlan
Quote
Kriggel23
Harlan,

I just faced the problem in 4077 as well, sorry ...

What I did was the following:
Entered first characters of existing thought into search field, pressed <cursor up> to navigate to entry in list of possible thoughts, pressed <return>.
=> Thought was made the active on (was not visible in plex before)

Activated tab "Properties & Attachments" with mouse.
=> Only one attached file is listed, being "internal", it's active (blue background) and the attachments-buttons are active (= not grayed but in color)

I left-click onto the Delete-Button.
=> No reaction, button does show NO reaction, it does not lower itself as being pressed nor am I asked whether I really want to delete the attachment.

I click into the white space of the attachments-list.
=> The file is deactivated (white background), the attachments-buttons (e.g. delete, cut ,copy) are now deactivated (grayed).

I click once onto the attached file within the attachment list (does not matter which column).
=> The attachment is activated again (blue background), the attachment buttons switch visibly to active again (= show color).

I click onto the Delete-button.
=> same as before, no reaction.


My workaround, as mentioned:
Right-click on thought in plex, "Delete attachment ..." and confirm ..

Could not identify an event or action which initiated the "do not react to attachment buttons". Normal working before, e.g. moved some files (plain text and outlook MSG-files) as new thoughts to PB4, activated some thoughts, opened some attachments (XLS, DOC) for editing, saved them. One hereby opened XLS is still open for editing.

Kind regards,
Kriggel23



Quote
Harlan
Thanks for the detailed description. The handling of attachments and their commands has been rewritten in version 4078, which is the current beta. If you experience this problem once you have upgraded to 4078, please let us know. 4078 has a different attachment command issue however, related to right clicking on thoughts and selecting attachment commands. You may want to wait for 4079 to upgrade as I think this will solve both problems.
Regards,
-Harlan
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software