zenrain
I've had this issue since I first upgraded to 4.x, so I don't think it's normal behavior as it's different from the 3x behavior, but I can't be sure.
Anyway, the Active thought indicator only rotates smoothly when my mouse is moving around in the plex. If my mouse pointer isn't moving around, then it stutter rotates extremely slowly. Is anyone else experiencing this?

PB ver 4.0.7.8
Java 1.6.0_01
Windows XP Pro SP2

Windows 7
J-1.6.0_22
--
OSX 10.6.3
Java SE 6
Quote
Spacenexus
Yes i've noticed that too. Hadn't considered it to be unusual before, but now that you mention it I agree, constantly smooth rotation should be the soup of the day independent of mouse movement.

cheers

Jim

PB4078
Java 1.6.0 (build 1.6.0_02-b06)
OS XP2002 SP2
@181218:
TB8022 32bit
Java 32bit Version 8 Update 141

Firefox, Office 2013 Pro Plus 32bit
64bit Win10Pro
64bit Primary Laptop, 8GB RAM, Intel Core i7
64bit Secondary Laptop, 64GB RAM, Intel Xeon E3
Brain user since zygote
Quote
Harlan
In 4.0, the rotation slows down to conserve CPU cycles while PB is not in use.
Regards,
-Harlan
Quote
julianh
I'm not sure the rotation is behaving quite how was intended. The brain seems to judging 'inactivity' in a strage way, in that it only allows the animation to proceed at the full pace while there is some mouse events going on such as mouse movement on ButtonDown - I would imagine a better indicator of inactivity would be when the window looses focus? Also, was it intended that the slowed roation would turn quite as slowly as it does, around one (very small) frame/second - when its that slow it may as well not be rotating.

On my machine the animations take up a tiny amount of cpu so I'd quite like a configuration option as to whether it does slow the animation when the brain is 'inactive' and like I say, i think window focus or some timeout of lack out mouse/keyboard activity would be better indicators of when the brain is not in use.
Quote
zenrain
I was thinking the same thing. Good thing you wrote it down!
Windows 7
J-1.6.0_22
--
OSX 10.6.3
Java SE 6
Quote
mcaton

One option you may want to explore is simply turning the Active Thought Indicator off.  It certainly isn't a mandatory component.  This can be easily done in the PREFERENCES window under the OPTIONS tab.  Expand the PLEX section and uncheck ACTIVE THOUGHT INDICATOR.

Quote
zenrain
I actually have tried it, but when you have an expanded brain, it makes it harder to find the thought.
Plus, having used the active thought indicator since I've been using the software, it feels like something is missing when it's gone. It's just so peaceful and mesmerizing...


Windows 7
J-1.6.0_22
--
OSX 10.6.3
Java SE 6
Quote
julianh
Yeah, I agree, I find it quite relaxing to see it spinning away.
Quote
Harlan
We'll see about adding an option to keep rotation going as long as the window has focus.
Regards,
-Harlan
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software