ruudhein
Maybe I'm not catching something but I'm trying to set up a link type that defaults to a one-way link -- but it doesn't do what it says on the box:

1.jpg 
2.jpg 

3.jpg 

Note that in this case the arrow doesn't appear either. Sometimes it does but even in that case the parent may still show:

Here is a case where 2 links have received the same link type with a one-way default. Both show an arrow. One will work, one doesn't:

a.jpg 

b.jpg 

c.jpg 

d.jpg 

Weirder yet; opening the link type editing can toggle this. As in: if A showed but B didn't, now it will reverse.

Either way, unless I set the direction on the individual link, I can't get this to work.
Using: Evernote | FilterizeEverdo | Dynalist | Liner | TheBrain v9.1.8.0
Quote
mcaton
Ruud,

Thanks for posting.  I'm still trying to set up a One Way Thought Type where the arrows do not show up.  I have not been able to re-create this yet.

Also, if you have just navigated from the Parent where the one way link occurs and is supposed to be displayed, you'll still see the parent when you click on the child thought.  However, if you click on the child thought from a search result... or find it in the past thought list, the Parent will not be displayed. This is by design.  Does this explain your Quote/Statistic scenario?

If not, a quick video may be helpful to see how your are navigating to/accessing these Thoughts.

Thank you,
Matt
Quote
ruudhein
Thanks Matt, that helps explain the behavior I see in my test brain (the last 3 screenshots).

It partially helps in my real brain (the first 3 screenshots).

What it doesn't explain is the situation without arrows or without correct one-way linking via the link type defaults.

I've been toying around a bit and this seem to be the case:

  • (un)setting one-way and/or (un)setting arrows on the link overrides the behavior of the default's of the link type
  • this remains true no matter what: you can (re)assign the link type all you want, the link type default's arrow + one way setting will not come back
  • this will also happen if before applying a link type with defaults you have manually changed anything on the link

So, from the moment you have touched the arrows or one-way setting on the link itself, there is no going back to getting an assigned link type's defaults operating on that link. The only way back is to unlink, relink, then apply the link type.

v239
Using: Evernote | FilterizeEverdo | Dynalist | Liner | TheBrain v9.1.8.0
Quote
mcaton
Ruud,

I think I get it.  The link direction loss is a result of the link that has a Link Type being edited.  This is very helpful.  I'll resume testing.

Thank you,
Matt
Quote
mcaton

Ruud,

Aaaaand replicated [smile]  Now that the link direction has been removed, it is expected to fall back on the Type setting (the same as it would with an Thought image/Thought Type image scenario.

I'll document this for further review.

Thank you,
Matt

Quote
ruudhein
Great! And just for sake of being complete: this will happen if you edit the link direction before or after assigning a Type.

Thanks Matt!
Using: Evernote | FilterizeEverdo | Dynalist | Liner | TheBrain v9.1.8.0
Quote

Add a Website Forum to your website.

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software