Jim Show full post »
jostber
Shut down PB and reedit the preferences file when PB is not running. Do this to check that you have changes every instance in the file to "html=google-chrome,firefox":

grep html= ~/PersonalBrain/res/Def*s



TheBrain 8.0.2.2 Slackware 14.2 KDE 4.10.3 Java 1.8 / (Windows 7)
Quote
cd

Hi all,

old thread, but hey: there's still one more thing you could look into.

- Check /etc/mime.types for relevant mimetype(s) (here i suggest esp. "text/html" (and then maybe some of application/xml* if you need it, know what you're doing and your browser supports that)
- Edit /usr/share/application/default.list and find the mime types from above, replacing application name with an application available within the directory /usr/share/applications/ as "APPNAME".desktop
- if you use nautilus (i don't), restart nautilus (running "killall -1 nautilus" from a command line or wait for next reboot)

This will set the default application for any mime-type system wide on gnome or kde systems. Changing this on a per user basis would probably be done in ~/.local/applications/mimeapps.list and default.list resp., these will override the global system default mentioned above. 

Cf. here and e.g. here for more info.

Cheers
Chris

-- 9.0.250.0 (9.0.250.0) on Mac OS X 10.12.6
   Old enough to remember Natrificial times...
Quote
woelke
I am having a problem in which I need an website to open in Internet Explorer but it always defaults to Firefox. I am a simple user so I need a simple answer

Thank you
Quote
Moe
Hi woelke,

Thank You for posting. Check the following link to Microsoft's site on how to change your default web browser to IE.

Thanks,
Moe
Quote
ChrisCase
After having to reinstall Windows, and then reinstall PB 6.0, I found it opening links in Internet Explorer rather than in Firefox.  I removed IE, and now it won't open links at all.  I downloaded the DefaultUnixCOmmands.properties file and saved to to the Res folder.  Buit it does not appear in the folder, nor come up in any search, despite apparently having been saved.

So how canI get PB to open links, and in Firefox?
Quote
pthompson
Chris,

Make sure you have Firefox set as your default browser in Firefox's settings.
Quote
paperoga
No solution in these years ? A simple workaround that works indeed, is creating a symlink in /usr/bin/firefox , for example, pointing, in my case to /usr/bin/icecat.
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software