rustyedges
Here is a laundry list of buggy behaviour from my full time use the last several days...


horizontal rules (which I make liberal use of) cause all kinds of problems with cursor movement and editing

  • arrow down or up until reach a horizontal rule, then jumps either to top of notes or up to middle of some content?
  • Ctrl+right arrow on line of text above rule to jump past word, it jumps to end of entire notes.
  • put a horizontal rule at top - no way to arrow up above it
  • have link and horizontal rule, the cursor just disappears or goes to top


embedded hyperlinks also have several issues

  • unable to place cursor after a link, as it is always forced before the link icon. I keep pasting links then typing or creating new line, the icon/button gets moved
  • tried typing before a link, and it changed the link to some crazy format (//blogs.windows.com/<spanhttps: class="mce-spellchecker-word" data-mce-bogus="1" data-mce-word="msedgedev">msedgedev/2016/05/24/fetch-and-xhr-limitations/)
  • paste a link, hit enter (so can go to new line and start typing), but the cursor has jumped up into the beginning of the link itself, splitting it apart


shows old/previous notes contents when navigating to new thoughts until actually click into Notes editor
sometimes even this won't work and have to needlessly navigate around a couple times and come back for it to refresh

Find & Replace dialog - expect to open and start typing word to find, except the cursor is actually behind the dialog typing into notes
sometimes, I can't even get it to accept the cursor the first few times trying to click into it


Problems with non-paragraph new lines (using Shift+Enter) causing cursor to jump within above line
if you come back to the line, the cursor jumps up. If you try and right click and paste to match format, it pastes starting within the line above. backspacing to delete jumps up within above line


Others...


not sure what I'm even doing, but keep getting a contextual menu on upper left of screen that includes "view source" option - how I know it is from the notes editor
Quote
mcaton
Quite the list indeed!  I'm working through and documenting now - may have a few screenshot and further detail requests as I go.

Thanks for sharing!
Matt
Quote
mcaton
Tried replicating the issue you mentioned above:

Quote:
  • tried typing before a link, and it changed the link to some crazy format (//blogs.windows.com/<spanhttps: class="mce-spellchecker-word" data-mce-bogus="1" data-mce-word="msedgedev">msedgedev/2016/05/24/fetch-and-xhr-limitations/)


Can you provide a screenshot of the Notes Editor Before and after?

Thanks!
Matt
Quote
mcaton
Russ,

Also, still trying to replicate the Note content not updating/refreshing.  Do you have Update displayed content on Hover checked?  Does the issue happen when it is not checked?

And finally, a screenshot of the View Source issue you mentioned would also be helpful.

Thanks again for posting.  A few new issues documented, others confirming issues we're already tracking and hope to have fixed soon.

Matt
Quote
rustyedges
Matt,

I can no longer reproduce the weird link issue, even using the same exact note/link where it first happened - and I did it again and again before reporting!  Not sure if x163 changed that but will assume some rare edge case not worth looking into.

For the note content not refreshing.  This is random but fairly common for me across my brains.  I do NOT have "update displayed content on hover" checked.  Here is example screenshot where I was on the "fetch api" thought trying to reproduce the above error, then clicked to navigate to Lambda thought and everything (including attachments list) has updated EXCEPT for the notes, which are still showing the old notes.  Clicking into the notes area refreshed in this case, but many times a restart is required.

notes note updated.jpg 

The contextual menu issue was much harder to produce as doesn't happen very often but is annoying as only way to clear is to actually click view source.  My best guess is that is related to using touchscreen to touch into notes but I really don't know.  I clicked around for several minutes and couldn't reproduce, then going about my work it just popped up again.  you can see in this next screenshot in upper part of window, and is always displayed in this same spot...

contextual menu.jpg   
Quote
mcaton

Russ,

Thank you for the screenshots.  Very puzzling and not able to replicate yet, but still testing and reviewing.

Thanks,
Matt

Quote
rustyedges
Thanks for the update.  The navigational and editing issues with rules and links are more important to me anyway
Quote
Mudhenn
Can confirm this:
Quote: paste a link, hit enter (so can go to new line and start typing), but the cursor has jumped up into the beginning of the link itself, splitting it apart
Run into that error today, somewhat irritating. The Brain 9.0.163
Quote
mcaton
Thanks Frank,

We've replicated and documented this error.

Matt
Quote
Mudhenn
rustyedges wrote:

horizontal rules (which I make liberal use of) cause all kinds of problems with cursor movement and editing

  • arrow down or up until reach a horizontal rule, then jumps either to top of notes or up to middle of some content?
  • Ctrl+right arrow on line of text above rule to jump past word, it jumps to end of entire notes.
  • put a horizontal rule at top - no way to arrow up above it
  • have link and horizontal rule, the cursor just disappears or goes to top


Five month in and still massive issues with horizontal lines. Is there a bugfixing planned?
Quote
mcaton
The horizontal rule behavior (#3712) is still an open issue that is being reviewed.

Thank you,
Matt Caton
Quote

Add a Website Forum to your website.

Newsletter Signup  Newsletter Signup        Visit TheBrain Blog   Visit TheBrain Blog       Follow us on Twitter   Follow Us       Like Us on Facebook   Like Us         Circle Us on Google+  Circle Us         Watch Us on Youtube  Watch Us       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software