Shuhart75

I think you know that your app have a problem: some shortcuts won’t work in notes, if user switches to non-latin keyboard layout.

 

I don't know how exactly you define those shortcuts in your app, but some time ago I've got a little chat with tapbots team regarding one of their products which had a similar problem.

They use a script to avoid sandbox. It used  a layout-dependend code, smth like this:

-- sigh, thanks sandboxing
tell application "System Events"
keystroke "v" using {command down}
end tell

They have changed it to

-- sigh, thanks sandboxing
tell application "System Events"
key code 9 using {command down}
end tell

and everything is ok now.
May be you'll look into this problem with notes, it's rather tiresome to change layout every time you need to use a shortcut. Thanks.

Quote
pthompson
Shuhart75,

Thank you for writing and sharing this information. I will document it.
Quote
Harlan
Please provide us with a specific example of what layout you are switching to and which shortcut is not working so we can replicate the problem you are experiencing.
Regards,
-Harlan
Quote
Shuhart75
Hello. Sorry, somehow I've missed your reply. Russian keyboard layout. macOS High Sierr 10.13.3, mbp 15'' 2017.

Shorcuts still work strangely. I should say that's the only reason I haven't bought the 9th version... yet 😉
Quote
mcaton
Shuhart,

Thanks for the update.  Can you also please give us a shortcut example that is not working for you? You also mentioned earlier that you didn't know how to define the shortcuts.  Please click on TheBrain > Preferences > Keyboard tab to customize your own desired keyboard shortcuts.

Thank you,
Matt
Quote
Shuhart75
I've mentioned earlier that I don't know exactly how you define shortcuts in your app's code )

https://www.dropbox.com/s/2m4ba3ymnkgv7l7/brain.mov?dl=0

Here's a video. First I cut and paste text in latin keyboard layout. Then I switch to Russian, and cutting and pasting stop working. Then I use Cmd-Q to quit TheBrain in Russian layout, but nothing happens. I change layout to latin, press Cmd-Q again - and TheBrain quits as it should be.
Quote
mcaton
Thank you for posting and for sharing the helpful video!  This issue is documented and under review.

Thanks,
Matt
Quote

Add a Website Forum to your website.

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software