jotapa
Hi Brain team,
just upgraded to version 117 on windows and the notes are not working again this time only when the notes box is on the right. Not sure if the problem is this version or a previous one because I haven't tried TB9 in a while.

This is a problem that I reported a long time ago (April if I'm not wrong) that seemed to go away months later with newer versions but is now back in a limited format.

Here's a screenshot:
2016-10-06 14_59_25-TheBrain.png 
Notice the information that there are 5 words in the notes but the text is not shown.

If I move the notes box position, everything seems to be working:

2016-10-06 14_59_48-TheBrain.png 
With this setup (notes below the plex), I can write normally and the text shows up as we would expect. Interestingly, If I move back to the right, the previous text shows up, but Everything else that I write does not.
2016-10-06 15_00_20-Program Manager.pngThe first five words can be seen but what I wrote with the notes box on the right does not show up - check the number of words at 23.

Glad to provide additional details if you need it.

Looking forward to seeing this fixed. 

Thanks.
Joao Tapadinhas
Quote
pthompson
Joao,

I just tested this on my macOS and Windows 10 machines on multiple Brains and Thoughts and cannot replicate the issue. Is this occurring on every Thought and Brain for you?
Patrick Thompson
TheBrain Technologies
Quote
jotapa
Hi Patrick,
I have this problem with Windows 10

On a side note, also tried with macOS Sierra (running on a VM in Windows 10) and the problem doesn't happen. The notes look fine except for some blinking when I'm writing... read somewhere that you're trying to fix that, so it's not a problem for me at the moment.

Back in April or May, you were never able to replicate the problem, even on Windows 10 but, somehow, it was fixed with newer versions. In the current version 117, there must be something different on the way you initialize/run the vertical and horizontal notes box.

It runs well in horizontal mode even if maximized. 
It doesn't work in vertical/right mode - neither with normal or maximized size.

Hope this helps.

Regards,
Joao
Quote
danlandrum
Joao,

They're still working on the problem with Sierra. Based on my GoToMeeting session with Matt, it doesn't sound like they were able to reproduce it in-house as of yesterday, but I'm running a very late model iMac with a 5k monitor, and they don't have one of these machines on which to test. Perhaps you could let them know about yours? It might help. The flashing and subsequent lag doesn't happen on my late 2013 MacBook Pro, but it is clearly still broken on in late 2015 iMac.

Dan

OSX 10.13 
iMac (Retina 5K, 27-inch, Late 2015)
3.3 GHz Intel Core i5
32 GB 1867 MHz DDR3
Quote
pthompson
Joao,

I have also tested on Windows 10 and cannot replicate the issue. Is this occurring on every Thought and Brain for you?
Patrick Thompson
TheBrain Technologies
Quote
mcaton
Joao,

Can we schedule a time to review your notes issue on your Windows 10 machine in a web meeting.  I'd like to see the issue step by step and maybe take a look at a few settings in the application to see if we can further isolate the problem.  Please feel free to contact me directly at matt@thebrain.com or send a note into support@thebrain.com with some times you could be available.

Thanks,
Matt
Quote
jotapa
In response to Dan's post:

Quote: Joao,

They're still working on the problem with Sierra. Based on my GoToMeeting session with Matt, it doesn't sound like they were able to reproduce it in-house as of yesterday, but I'm running a very late model iMac with a 5k monitor, and they don't have one of these machines on which to test. Perhaps you could let them know about yours? It might help. The flashing and subsequent lag doesn't happen on my late 2013 MacBook Pro, but it is clearly still broken on in late 2015 iMac.

Dan


My Mac setup is quite unusual - it's an macOS Sierra running as a virtual machine under Windows 10, on a very fast Surface Book. Although the host machine has very good performance, the mac software does suffer a slowdown for running as a VM - that's probably why I can notice the blinking while others don't. Slow / old mac machines could have a similar issue because the notes box does have a strange/inefficient refresh process.

Obviously, if it can be optimized I would appreciate and use the mac version more often in conjunction with other software... 




Quote
korm
Maybe it's just me, but I don't think I'd expect a software vendor to fix issues with their software when it is running inside OS X in a hackintosh environment.   Just saying.
Quote
jotapa
Agreed, korm. That's why this post was focused on the Windows 10 notes problem and just had a cursory mention to the macOS issue at a later stage.
Quote
jotapa
Last mail on this topic (I hope) - just learned that when we double click the separator line between the plex and notes, the notes box moves to the left.

The problem I reported on this thread DOES NOT happen if the notes box is positioned on the left but it totally does happen again, if I move it back to the right.

Left - good
Down - good
Up - good

Right - NOT good - the text doesn't show up, although it is captured and can be seen if I move it to one of the other positions.

I have plenty of workarounds for this problem now, but would suggest you check what is different when the notes box is active to the right of the plex.

Thanks,
Joao
Quote
mcaton
Great to know that you have a stable work-around.  Just odd that the issue only happens when notes are on the right!  

We'll continue troubleshooting and thank you for the extra details.

Also, I'm still interested in joining you for a web meeting.  I received your note and will set something up for early next week.  Thanks!

Thank you,
Matt
Quote
Harlan
Joao,

Can you check and see if the problem is related to the scale of your display settings being something other than 100% as was the cause for Fernando's issue with notes in Windows?

Windows 10:
  • Right click on desktop, then select Display Settings and move the slider to the leftmost position. Sign out and back in to allow all programs to adjust to the new settings
Windows 7:
  • Right click on desktop, then select Personalize, then click Display near the bottom left corner, and select "Smaller - 100%". Click Apply, the sign out and back in.
Regards,
-Harlan
Quote
jotapa
Hi Harlan,
just tested 100% and it seems to work. Looks like TB is not reacting well to Display scale.

It will need to work with other definitions. 100% is not an option when you have an external 4K monitor or a laptop with 3000x2000 resolution, like I do.

Anyway, glad we found what looks to be causing the problem.

Joao
Quote
Harlan
This is fixed in 9.0.123.
Regards,
-Harlan
Quote
danlandrum
Thanks, Harlan, huge improvement. A note to other users having this problem. The flashing didn't correct itself on my machine by simply updating to .123 and switching back to the iMac display profile. I had to quit and restart TheBrain, then the problem disappeared.

OSX 10.13 
iMac (Retina 5K, 27-inch, Late 2015)
3.3 GHz Intel Core i5
32 GB 1867 MHz DDR3
Quote

Add a Website Forum to your website.

Newsletter Signup  Newsletter Signup        Visit TheBrain Blog   Visit TheBrain Blog       Follow us on Twitter   Follow Us       Like Us on Facebook   Like Us         Circle Us on Google+  Circle Us         Watch Us on Youtube  Watch Us       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software