metta
Is anyone else having problems with the sync in the TB10?

I'm currently running TB10 on a Win7 desktop and, in the current and previous versions (10.0.13 & 10.0.11), the sync has been getting hung up and never resolves.

The only way I can stop the sync process is to close the entire application -- and then, when I reopen the TheBrain, I have the option of resuming the sync where it left off, at which point, the sync starts running continuously all over again.

A Help Desk ticket was created days ago, and output logs have been submitted -- so I'm mainly interested now in finding out if these problems with my installation are an outlier, or if there are others who have been dealing with this issue, as well.

Any feedback and updates will be appreciated.
Quote
DrBop
I did have this issue in .11 (on my Mac), and mentioned it incidentally in another post here. The upgrade to .13 seems to have corrected. 
Quote
vmilhoan
I've had issues on and off today - using Win 10 and version .13. I did have a successful sync within the last 30 minutes.
Quote
Dr_Bull
This morning was the first time I opened 10.0.13.0 and I have experienced issues with syncing.  I tried closing and reopening the app, but TheBrain continuously attempted to sync and never resolved.  As  I was writing this post, syncing behavior changed and began to fail immediately.  

 

Quote
pshanks

V10.0.13.0 - Windows 10

I've started having problems this morning. TheBrain hangs and becomes non-responsive.

Now I'm getting the following messages

 

2018-09-28_12-26-55.png 

2018-09-28_12-31-18.png 

TheBrain (Beta 10.0.14.0) 9.1.16.0, iOS V9.1.2, TheBrain 8.0.2.2
Windows 10 (V1803), Windows 7 SP1, OS X V10.13.5
Using The Brain since V3 (1999)

Quote
Dr_Bull
I have had a successful sync (Mac) since I posted. 
Quote
mcaton
We're happy to look at Output.log files if you'd like to send them into support@thebrain.com along with a description of what you are experiencing. Especially if you have an error message.  I can tell you that we've been experiencing heavy traffic with the announcement of v10 beta.  I too had a few "slow to respond/finish" syncs this morning, but when left alone, the sync should finish and not give errors. Syncs seem to be working great now.  

Thanks,
Matt
Quote
metta
@Matt ~

I'm still having NO success with syncing at all.

In fact, the sync will run continuously for 24 hours if I leave it alone -- and I haven't been able to resolve a sync in days, so my web client brains are completely out of date.

Several output logs have already provided -- and I'm receiving no error messages at all.

The sync simply gets hung up at various (different) stages in the sync process, as detailed in the Help Desk ticket updates I've already submitted -- and the only way I can stop the sync is to completely close TB.
Quote
Harlan
A sync problem was found and fixed in 10.0.14. Please try this.
Regards,
-Harlan
Quote
metta
Thank you, Harlan, very much for your help with finding a fix for this disconcerting issue.

Here's the update on my initial experience:
  • First attempt to download the 10.0.14 update failed, and the TB locked up completely. Had to shut it down manually using the Windows Task Manager.
  • Second attempt to download and install the new update succeeded, but when I resumed the sync that had been previously interrupted, the sync bug presented exactly as it did previously:
    > The sync stalled and ran endlessly while "Preparing remote data...."
  • Third attempt: Closed and reopened TB, and this time I selected the option to start over the interrupted sync (instead of resuming where it left off), and this time the sync finally worked.
  • Also successfully completed syncs on several other edited brains, and confirmed the recent edits in the web client.

At this point, the sync function does seem to be functioning, although it also seems to be taking longer than usual, ever after several days worth of updates have been integrated. I don't know if this is significant (or indicative of a problem), or not -- so I will upload an output log on my help desk ticket, in case the engineers want to take a closer look.

Thanks again.
Quote
kiatlc
Harlan wrote:
A sync problem was found and fixed in 10.0.14. Please try this.

I face the same problem with .11 and .13
after update to .14, one of my brain which previously show  'Resuming sync' can sync successfully
BUT the other brains still show "Preparing Remote Data"

so this version is not a total bug-free version

@Metta I face same issue with you, if not you make this post, I thought I am the only one having this problem, and frustrated for two days already
Quote
kiatlc
metta metta wrote:
I selected the option to start over the interrupted sync


how to select this option?
Quote
metta
Thank you for the feedback, Kiatic. I understand completely about the feeling of wondering if I'm the only one.....especially when no one else was reporting any sync issues. 😉

Regarding the option to "Start Over": I can't capture a screenshot for you since the sync is working now, so here's what I would do:

> Leave your current brains open (the ones that are displaying the sync error) and then CLOSE TheBrain application.
> Then reopen TheBrain.
> After TheBrain opens, try syncing one of the brains that was previously displaying the message "Preparing remote data"....
> At this point, I think you'll receive the "Interrupted Sync" dialogue box, and it should offer you 2 choices:
-- Resume
-- Start Over
> Select "Start Over" and see if the sync will resolve.

In my case, "Resume" only perpetuated the problem I was previously having with the sync.

In contrast, "Start Over" seemed to allow TB to get a fresh start (based on the new bug fix), and that allowed the sync to resolve as it should. Admittedly, it too a bit of time to sync since there were several days worth of updates, but it did eventually manage to finish.

If this does NOT resolve the problem for you, please let us know .... and provide as much detail as you can about the steps you've taken.

Alternatively, you can contact TB Support directly at the email address Matt provided above, and include screenshots and/or your current output log (available under the "Help" menu > Open Log Directory). This will allow Support to look for any specific problems that may be occurring in your TB10 installation.

Hope this helps! 🙂
Quote
Harlan
In order to get the option to restart, you will have to shutdown the app and reopen it. If an auto sync starts you will not get the option to restart. So you have to click and initiate a manual sync within 30 seconds of opening the app. 

The problem is a result of changes made to the sync process to support the brainbox. 
Regards,
-Harlan
Quote
Harlan
Thanks to everyone for helping out with the beta testing process. 🙂

Unfortunately it does mean that you will experience more bugs than usual as we are rolling out new technologies and features that have a high degree of variability in the real world that we can’t simulate adequately in our internal testing. 

While BrainBox may seem like a simple feature in use, it has a lot of moving parts under the covers that need to work in concert to provide a good experience for you all. Your usage in this early period helps to smooth that out for the future. 👍🏼
Regards,
-Harlan
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software