agnor
Upgraded to 4.5.0.5 this morning and continued working.

Created a thought called "Getting Started" under my current thought, went along creating other thoughts, and then decided that (because of the content matter) I wanted to rename my "Getting Started" thought to "Getting Started - What is Science?"

I renamed the thought, hit enter, saw the plex change, and then when I came back to it a few minutes later, the thought had reverted back to "Getting Started".  I tried it again, and sure enough, I can watch the thought change to "Getting Started - What is science?" the moment I rename it, and then it gets changed *back* to "Getting Started".

Tried it with another child thought of the current thought (current thought still active, and thus this second one is a peer of Getting Started), and it worked just fine.  Tried renaming "Getting Started" *again*, and this time it stuck.  I'm not sure why.

I'm attaching my output file.  I noticed that when the thought reverted, I got entries in my log.  however, when the thought successfully renamed and "stuck", there were no entries.  It's like PB recorded my rename, didn't like it, and recorded itself changing it back.  The entries in the log are preceeded by a tilde character.

Even though it apparently works now (in the middle of typing this post, no less), I wanted to post it anyways, just in case.

Windows XP, Pro PB 4.5.0.5 with indexing libraries, J-1.6.0_02


Quote
Harlan
Yes, that is strange indeed. What method are you using to rename? (Right click, F2, or  Properties) Is it active when you try and rename? (or are you using the mouse or keyboard to highlight it?)

Regards,
-Harlan
Quote
steve625
I had the same issue on rename using the F2 button.  Although mine never "stuck" I ended up creating a new thought.  My new problem is when I tried to delete the old thought it came up with an error  (sorry forgot to note the error), I closed my brain and now it will not reload.  I downloaded again, and reinstalled.  When I click on "Finish" it will show the opening box for a few seconds, then it's just gone, no program, no msgs, no error.

log
Quote
Harlan
steve625 wrote:
I had the same issue on rename using the F2 button.  Although mine never "stuck" I ended up creating a new thought.  My new problem is when I tried to delete the old thought it came up with an error  (sorry forgot to note the error), I closed my brain and now it will not reload.  I downloaded again, and reinstalled.  When I click on "Finish" it will show the opening box for a few seconds, then it's just gone, no program, no msgs, no error.


It looks like your indexing libraries have been corrupted somehow. Never seen that one before...

Please delete the folder Program Files\PersonalBrain\bin\filter. Once you have deleted the filter folder, try restarting PB again. You will be prompted to download the indexing libraries again. Do not do so immediately. Please first verify that all is working properly again. If it is, then you can re-download and install the indexing libraries again. Let me know how it goes. Thanks.

Regards,
-Harlan
Quote
steve625
Quote:
Let me know how it goes. Thanks.


Everything is working fine.  I have reinstalled the indexing libraries, and all seems to be back on track.  Thanks for all your help.  TheBrain has great customer service.  No wonder you keep winning all the service awards.   Thanks again.

Quote
agnor
Harlan wrote:
Yes, that is strange indeed. What method are you using to rename? (Right click, F2, or  Properties) Is it active when you try and rename? (or are you using the mouse or keyboard to highlight it?)


I know for sure that the thought I was renaming was *not* the active thought.  Here's what it looked like:



with the culprit thought made brighter for emphasis.

I'm in the habit of using F2 to rename.  Combined with it not being the active thought, I likely moused over it, punched F2, and then went for the rename.  And it was definitely before the thought had any attachments.

At first, I thought it was the dash and/or the question mark, but I was unable to duplicate it on another thought with a dash it in (even if I threw in a question mark).
Quote
Harlan
Ok, well if you see it again, please try and make a note of exactly how you did it so we can replicate it and fix it. Thanks.
Regards,
-Harlan
Quote
Darkstar
I use F2 to rename thoughts A LOT, and I can confirm this issue.

I will select the active thought or a child thought, hit F2, make my change, and enter it.

Then, the thought APPEARS to not have accepted the change! Ouch! But I've discovered that the thought has actually been changed. This can be confirmed by exitting the brain and restarting, swapping away from the thought to a new plex view when in Normal view, or by swapping from Extended View (my preferred display mode), swapping to an entirely different thought (so the renamed thought will no longer be visible--- ie, causing a an entirely different display in the plex to be displayed), and then coming back to the thought.

That behavior means that the plex isn't being told to update that already displayed "renamed" thought or that it is somehow getting repainted with the old name value rather then the new name value.

I've noticed a LOT of those "old display values" being used after changes to thoughts are made (while I'm in expanded view). For instance--- change the color of a thought. Sometimes you have to force the now "old" thought currently on the plex to disappear and then come back via some means. Sometimes you just need to make it the active thought. I'll try to get the exact repeatibility down for future reporting.
-Darkstar
Quote
Harlan
That sounds like an expanded view problem. We'll check into it. Thanks.
Regards,
-Harlan
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software