mctrexler
I was switching from one brain to the other (between two quite large brains) using the buttons at the top of the screen.  I received a message to the effect of "out of memory," coupled with a "restoring from automatic backup" message, but nothing happened.   When I tried again I received a "can't find any valid thought" message.  Now when I go into that brain through the *.brain file it's just a blank screen, or it just shows me the opening screen from the brain I was previously in.   The GBs of files are still in the brain's folder structure.   But is there a way to get the Brain back without having to go to an outdated Brainzip file.  

Is there a problem with the process of switching between brains.  Are there circumstances when you shouldn't do that? 

Quote
Moe
Hi mctrexler,

Thank You for posting. To the extend I am aware of there is no problem with the process of switching Brains using Brain buttons. Can you make a backup copy of your Brain by making a copy of your .brain file and your _brain folder then try forcing a rebuild of your Brain database to see if it helps. Below are instructions on how to force a rebuild of your Brain database. If that does not resolve the issue, please forward us a zipped copy of your _brain folder to support@thebrain.com so that we can further assist.

  1. Close PersonalBrain if open.
  3. In your "_brain" folder locate the folder called "brain_db". Rename this folder to 
      "brain_db_old1"
  4. Open PersonalBrain, then launch the ".brain" using the File > Open Brain
      command.

Thanks,
Moe
Quote
mctrexler
Moe, thanks for the note. I tried forcing the rebuild, and it looked like it was rebuilding, but at the end of the process there was nothing there.  I've switched the damaged brain with a duplicate from about three weeks ago, and happily I had not done much in the interim.

I have kept the damaged brain, but between its size (10GBs), the confidentiality of some of its contents, and the fact that it won't zip without my changing numerous filenames with apparently special characters, it doesn't turn out to be practical to send it to you for more analysis.  If you have more suggestions I'm happy to try them. 

So I'm back in business, although I will be a lot more careful about backups. My best recollection is that I might have pressed one of the brain buttons at the top of the screen, realized I had meant to press another button for another brain, and then immediately pressed that other button.  Perhaps I got confused somehow, leading to the out of memory and then no valid thoughts found messages.

Thanks for your help, Mark

Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software