pshanks
[V9.0.155.0 - Windows 7]

I've had the latest build V9.0.155.0 crash a few times this morning.

Output log and ErrorReports attached for review.

TheBrain Beta 9.0.236.0, iOS V9.0.4.0, TheBrain 8.0.2.2
Windows 10 (V1709), Windows 7 SP1, OS X V10.13.1
Using The Brain since V3 (1999)

Quote
mikesingleton
Me too, error log files attached
Quote
Harlan
Thanks for the posts.

Mike's errors have been written up #3548 and 3549.

Pat: Your issue has been logged as #3550. It looks like the database was busy during your errors. Were you doing anything unusual when you encountered the problems? (Running a slow report, exporting, importing, syncing or anything else that takes longer than a few seconds) Can you still reproduce them? If so, please describe how.
Regards,
-Harlan
Quote
pshanks

[V9.0.155.0 - Windows 7]

Nothing unusual, I was just trying to access attachments on a Thought.
It looks like The Brain was syncing at that time.

Here is a video showing what I'm doing.
=> https://www.screencast.com/t/H0nBwPc5

And the ErrorReports that got generated and the Output log.

Thanks,
~ Pat

TheBrain Beta 9.0.236.0, iOS V9.0.4.0, TheBrain 8.0.2.2
Windows 10 (V1709), Windows 7 SP1, OS X V10.13.1
Using The Brain since V3 (1999)

Quote
Harlan
Hi Pat,

Thanks for posting the additional error logs and video. They were very helpful.

We are pretty sure that this is happening because of the combination of: A. The background sync. B. Recently introduced inefficiencies in the sync code (that we have since fixed for the next build). C. The database running unusually slowly on your computer.

Regarding C: Is this the same computer where deleting a handful of thoughts at once would take multiple seconds to finish? If it is, then that is why you are seeing this problem while no one else has reported it yet. We have not been able to replicate those speed issues you showed us, found no obvious problems in the relevant code, and have had no other reports.

Perhaps there is something unusual about that machine. Please let us know the specs of that machine: CPU, RAM, HD (total size and space available). If you wouldn't mind, please download and run this benchmarking tool to see if there could be a problem with the HD. Make sure to run the benchmarking test on the same drive where your Brains are located. http://www.techspot.com/downloads/6014-as-ssd-benchmark.html
Regards,
-Harlan
Quote
pshanks

Hi Harlan,

This is the machine I was using that had the challenges.

Windows 7 SP1 - 64 Bit
CPU: Intel Xeon E3-1290 V2 3.70GHz
RAM: 16GB
HD: 1.8TB (1.12TB Free)

I'll run the AS SSD Benchmark over the weekend and let you know the results.

Also regarding C: If we look at comparing the V8 to V9 I still finding the speed of the V8 database to be faster than the V9 database. I really like all the new features of V9, but overall I'm still finding that V8 (For me) out performs V9 in lots of case. I understand that V9 is beta, but some days it seems that V9 is lagging and I don't see the speed that is supposed be coming out of it yet. Mind you the last couple of builds I have seen some improvement.
 
All my other apps that I run on that machine don't seem to be impact at all, but V9 just has this lagging feeling.

Thanks,
~ Pat

TheBrain Beta 9.0.236.0, iOS V9.0.4.0, TheBrain 8.0.2.2
Windows 10 (V1709), Windows 7 SP1, OS X V10.13.1
Using The Brain since V3 (1999)

Quote
Harlan
Yes, V9 is slower on your machine. But we haven't seen that happen on any other machine or had any reports of it. There must be something wrong... 18 TB on that hard drive? That's a really big drive. Perhaps that is the reason. Look forward to seeing the results of the benchmark.

In any case, in 9.0.156 (available now), B is fixed so that will likely alleviate the issues though it still doesn't explain whey that machine is running V9 slowly.
Regards,
-Harlan
Quote
Harlan
That drive isn't a network drive by chance is it? If so, then that is the source of all the issues you are having. TB9 requires that data be stored on the local drive or performance suffer badly.
Regards,
-Harlan
Quote
pshanks
Sorry that should be 1.8TB... forgot the decimal [rolleyes]

And that disk is local on that machine and it's only hard drive.

TheBrain Beta 9.0.236.0, iOS V9.0.4.0, TheBrain 8.0.2.2
Windows 10 (V1709), Windows 7 SP1, OS X V10.13.1
Using The Brain since V3 (1999)

Quote
Harlan
OK, got it. Have you had a chance to run that benchmark yet?
Regards,
-Harlan
Quote
Harlan
Hi Pat,

Would still really like to see that benchmark so we can get an idea if that is the cause of the poor performance on your machine. Please let us know.
Regards,
-Harlan
Quote
pshanks

Hey Harlan,

Sorry it took so long.
Here is my benchmark for my Windows 7 machine - HDD

TheBrain_01.png 

Here is my the benchmark for my new machine Windows 10 (32GB, 512GB-SSD, 1.8TB-HDD), I will be installing The Brain on this SSD.
512 GB - SSD

TheBrain_02.png 

Windows 10 - HDD

TheBrain_03.png 

Yea, there is a big difference on the SDD, but not a huge difference on the HDD.
Thanks,
~ Pat

TheBrain Beta 9.0.236.0, iOS V9.0.4.0, TheBrain 8.0.2.2
Windows 10 (V1709), Windows 7 SP1, OS X V10.13.1
Using The Brain since V3 (1999)

Quote
Harlan
Thanks for running those tests and posting Pat.

I believe the hard drive speed is indeed the problem. If you compare your Windows 7 and Windows 10 machines, it is actually a huge difference. The Windows 10 machine is nearly twice as fast. Obviously the SSD is much much faster, but 90% faster (40 vs 21) is still a very big jump. If you upgrade the drive I am sure you will see a proportionate performance increase.
Regards,
-Harlan
Quote

Add a Website Forum to your website.

Newsletter Signup  Newsletter Signup        Visit TheBrain Blog   Visit TheBrain Blog       Follow us on Twitter   Follow Us       Like Us on Facebook   Like Us         Circle Us on Google+  Circle Us         Watch Us on Youtube  Watch Us       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software