CaptainJustice Show full post »
sibleyd
Am I missing something? The video seems to show near instantaneous response.
Quote
dlorde
I've noticed this too - on v9 there's often a noticeable pause after clicking on some thoughts before they get centred; it's not consistent, but I think it happens mostly on parent thoughts with many children. Setting the animation speed faster only makes the movement after this pause quicker.

I was just playing with thought activation to see if I could spot a pattern, and found on one occasion I had to click three times on a thought before it expanded. Not sure what's going on there, but maybe activating a parent thought parses the tree of children before updating the UI?
Quote
marcus
@sibleyd - the slowness in the video can be seen when you look at the time it takes for the mouse to move over a thought until the thought turns green. You can also see if if you turn your volume up. You can hear the mouse click, then it usually takes a second before anything happens. When the animation begins, it's usually pretty fast, but there's a significant lag from the time of user input to UI response.
Quote
zenrain
Marcus, it appear to only be sluggish on specific thoughts. You might try turning off Embedded Browser and or Previews in Preferences > UI to see if that resolves it.
If so, and it is due to the preview, one of the things I do for particularly slow websites is to just add a note. That way it only has to load the note instead of the entire site, and I can still switch attachment tabs if I need (and it's way better than losing the web preview or document preview for everything)
macOS 10.13
TheBrain 9.0.239
Quote
Harlan
Please try turning off Preferences > UI > Update content on hover and see if that makes a difference. If it does, that will help us know where the issue is. 
Regards,
-Harlan
Quote
marcus
Turning off previews speeds it up some, and turning off expanded mode makes it even faster. For now, I'll just use it that way, though I would very much love to see expanded mode work as fast as it does in v8!
Quote
Harlan
We narrowed down the cause of the problem to the display of distant thoughts in the expanded (normal +) mode and have fixed this issue in 9.0.232 (out now on the alpha channel). Thanks for your help.
Regards,
-Harlan
Quote
ascetic
232 has no difference with other version , always on high CPU occupation and so much sluggish. I have turn off hover option.
Quote
CaptainJustice
ascetic wrote:
232 has no difference with other version , always on high CPU occupation and so much sluggish. I have turn off hover option.

I am on .226 and not experiencing anything like this. Machine is a Surface Pro 4, i5 processor, 8mb ram, 256gb SSD. And I have the hover option ON.
--
The Cap'n
Quote
ascetic
My notebook also has SSD drive , i5 processor ,8gb ram. no other software are active on background. 
It is a very common issue. people who has i7 processor also meet the same.
you just make your brain thoughts more complicate and in expand view, and I guess you will have the experience .
Quote
Harlan
ascetic wrote:
My notebook also has SSD drive , i5 processor ,8gb ram. no other software are active on background. 
It is a very common issue. people who has i7 processor also meet the same.
you just make your brain thoughts more complicate and in expand view, and I guess you will have the experience .


If you are in normal + (expanded) view, there should be a dramatic difference between 9.0.232 and 9.0.231. If you are not seeing it, then you must be experiencing a different issue. Please post a screenshot of what you have onscreen when the problem is happening.
Regards,
-Harlan
Quote

Add a Website Forum to your website.