acant05
Entering a new thought name when the word is not in the spellchecker database causes a significant delay that impairs productivity. Is there any way to stop the spell check while entering thought names? I am not referring to the notes editor.

Search other than quick search doesn't work for me. Have rebuilt search index and database to no avail. Have installed 5.5.0.1b indexing version and 5.5.0.3b pro version. Neither work. I am getting no error messages. When I choose to rebuild the index there is a message saying  "the index seems to be missing some elements."

Running Vista 32 SP2 & JRE 6.15

Al Cantley
Quote
Moe
Thank you for posting. You can turn off Thought spell checking via Options > Spellcheck Thoughts. If extended search does not work please try the following.

  1. Close PersonalBrain.
  2. In your "C:\Program Files\PersonalBrain" directory, locate PersonalBrain.exe, right click then select Properties. Select the Compatibility tab. Under Privilege Level check "Run this program as an administrator".
  3. Restart PersonalBrain.
  4. Rebuild Search index via File > Utilities > Rebuild Search Index.
  5. Close PersonalBrain, then go back to the location in step 2 and un-check "Run this program as administrator" hit OK.

Best regards,
Moe


Quote
Grid_Guy
Just tried Moe's suggestion for restoring extended search by re-building with administror privileges turned on, but alas, no joy. Search is still inaccurate and the re-build utility still says "some elements are missing."

What else do you have?
Quote
acant05
It seems to be working for me; the index is currently rebuilding... Will not know for sure until I test with a search. Will report back later.
Al Cantley
Quote
acant05
Moe,

I followed your instructions. Index rebuilt in 30 hours! Search worked fine afterward. I closed PB; reopened normally (not as admin). A message popped up saying that the index was DROPPED - do you want to rebuild to test?... (not exact wording). Answered yes and the indexing restarted; I closed  PB and reopened. Search no longer works and no index is rebuilding. Go figure.

I'm stumped.


Al Cantley
Quote
Harlan
If you start a reindex, you need to let it finish. If it does not finish and you stop it at the beginning, most of the index will be deleted. There is no message that says index "dropped" maybe you mean "locked". If this is the case, that means PB was not shut down properly. You do not have to rebuild after a locking, it is just possible indication that the index may not be completely up to date. In most cases, I would not rebuild after a locking issue.

FYI, indexing can take a long time because it downloads all the URLs in your Brain. Also, all attachments need to be converted to text format.
Regards,
-Harlan
Quote
acant05
Harlan,

Thanks for the reply.

I did let the index completely finish the first time before closing. You are right, the message probably did say locked instead of dropped... So each time PB is closed and reopened the index will be locked, checked, and updated? Also, will it hurt to always run PB in admin. mode since mine is a single user machine?

As far as I know PB was the only Java app running and I got another error this AM; a system error message repeatedly says Java has stopped working - details follow:

"Java has stopped working..."

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    java.exe
  Application Version:    6.0.150.3
  Application Timestamp:    4a6ad1a7
  Fault Module Name:    StackHash_1703
  Fault Module Version:    0.0.0.0
  Fault Module Timestamp:    00000000
  Exception Code:    c0000005
  Exception Offset:    74207269
  OS Version:    6.0.6002.2.2.0.256.1
  Locale ID:    1033
  Additional Information 1:    1703
  Additional Information 2:    2264db07e74365624c50317d7b856ae9
  Additional Information 3:    1344
  Additional Information 4:    875fa2ef9d2bdca96466e8af55d1ae6e

Thanks.



Al Cantley
Quote
Grid_Guy
My experience seems to be tracking pretty closely with Al's. After experiencing the problem where joining an attachment results in the thought description being replaced by the title of the attachment (this is reported elsewhere in the beta forum), I removed version 5.504 and reinstalled 5.501, which so far seems to be the most stable of the 5.5 betas.

Once done, I then attempted re-indexing the search db while running PB in administrator mode. This seemed different than when I attempted it with 5.504 -- it was taking longer, which I found encouraging. I also let it complete, but then when I opened PB in normal mode, I also encountered the "locked" message and not realizing that it would undo the rebuild, gave permission for it to re-index all over again. Of course after that, searches were still incomplete, as before.

I will retry again, this time ignoring the seemingly aberrant "locked" notification, but I notice that 5.505 was released last night and might as well do it using that version. Having had to uninstall 5.502, 5.503, and 5.504 though, I'm going to wait a day or two and see how stable 5.505 is before my next attempt.

Harlan and Moe -- a sincere thanks to you for monitoring these issues so closely. It's a great way to develop great software. Glad if I can contribute.
Quote

Add a Website Forum to your website.