on my iPad, the v10 beta does not work (both versions mentioned in the topic).
Version 9 does work correctly as seen here:

As soon as I start the v10 beta, just a few seconds after the app has been started, it will crash.
My Brains are also not showing up and if I quickly tap on the settings symbol, the following screen is shown:

I have the same issue!
MacBook Pro 13" 2019 2.4 GHz 16GB
TheBrain Pro License 
Secondary screen Dell 2715Q 27" Ultra HD 4K Monitor resolution 3840x2160
iPhone 7 Plus | 256 GB | ios 13 | TheBrain
Actual Beta ( does work for me now.
Though I'm not sure if i was not patient enough int the past because with, it also took about 30 sec. before my brains were showing up.
I've had issues like this and have been going back and forth with support.

What worked for me was when in a desperate attempt I QUICKLY created a brain in the few seconds the app stayed open. Just named it whatever letter, bam, there we go. THEN the app stayed open AND my other brains loaded AND they worked.
Using: Evernote | FilterizeDynalist | FeedlyPrintFriendly | TheBrain v11.0.42.0

(Windows 10)

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software