bmac
I have installed thebrain on a Surface Pro 2 running windows 8.1. After the install (yesterday) it did work fine but today, it won't load with windows stating that thebrain.exe has stopped. Is there a log that would help explain why this happening?
Bill
customized Desktop PC (Haswell i7 4770 3.4 gHz with 32 GB RAM), Windows 10 Pro 64-bit, 256 GB SSD,  and a Microsoft Surface Pro 6, Windows 10, 512 GB SSD, 16 GB ram, i5
Quote
bmac
here is an eventlog for the issue:
Log Name:      Application
Source:        Application Error
Date:          12/30/2013 8:12:58 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Bill-Surface
Description:
Faulting application name: TheBrain.exe, version: 0.0.0.0, time stamp: 0x52540dfb
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x8c001900
Faulting process id: 0x1138
Faulting application start time: 0x01cf0560d6cd75be
Faulting application path: C:\PROGRA~2\TheBrain\TheBrain.exe
Faulting module path: unknown
Report Id: 19ad9f11-7154-11e3-8264-281878d7db24
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-12-30T13:12:58.000000000Z" />
    <EventRecordID>2097</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Bill-Surface</Computer>
    <Security />
  </System>
  <EventData>
    <Data>TheBrain.exe</Data>
    <Data>0.0.0.0</Data>
    <Data>52540dfb</Data>
    <Data>unknown</Data>
    <Data>0.0.0.0</Data>
    <Data>00000000</Data>
    <Data>c0000005</Data>
    <Data>8c001900</Data>
    <Data>1138</Data>
    <Data>01cf0560d6cd75be</Data>
    <Data>C:\PROGRA~2\TheBrain\TheBrain.exe</Data>
    <Data>unknown</Data>
    <Data>19ad9f11-7154-11e3-8264-281878d7db24</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>
Bill
customized Desktop PC (Haswell i7 4770 3.4 gHz with 32 GB RAM), Windows 10 Pro 64-bit, 256 GB SSD,  and a Microsoft Surface Pro 6, Windows 10, 512 GB SSD, 16 GB ram, i5
Quote
HeinrichUnger
Hm no Problem with W8.1 since beginning
Quote
pthompson
Bill,

I have no issues on my Windows 8.1 machine. Please make sure you are using the latest version of TheBrain, available here: http://www.thebrain.com/products/thebrain/download and the latest version of Java, available here: http://www.java.com/download. If you are still having trouble after this, please feel free to email support directly at support@thebrain.com for additional help.
Quote
bmac
This is the strangest thing. As I mentioned earlier, when the brain was initially installed, everything seemed to work fine. The next morning it would not even load. I initially uninstalled and then reinstalled but it would not load. And then, using the functionality of Revo uninstaller, which does a good job of removing registry entries, and other items created in the initial install, I finally got the brain to work again upon a new installation. Obviously something happened that corrupted some entry in the brain which Windows did not like. I have spent most of the day installing programs on the new surface Pro 2 and possibly one of the subsequent installations negatively impacted the brain.
Bill
customized Desktop PC (Haswell i7 4770 3.4 gHz with 32 GB RAM), Windows 10 Pro 64-bit, 256 GB SSD,  and a Microsoft Surface Pro 6, Windows 10, 512 GB SSD, 16 GB ram, i5
Quote
GRSaunders
I've had the same problems with Windows 8 and now Windows 8.1 Pro with TheBrain 7 and 8.  Works fine on Windows 7.

I have the latest everything...TheBrain and Java.

TheBrain is unreliable on Windows 8/8.1 Pro for me.  It crashes frequently and then occasionally it gets totally corrupt and won't load, saying thebrain.exe stopped...

Uninstalling and reinstalling it does not work.  I too had to use Revo Uninstaller and remove all the other files that it was not uninstalling to get it to work again.  

By doing that I came to find out that the culprit is TheBrain8Preferences.xml in the Users\account\AppData\Roaming\TheBrain directory.  

I have made a backup of this file and every time it permanently crashes (~3 times per week) I need to overwrite this file with my backup.

This doesn't explain the random closing of the application every few hours with no error messages...

I also have the already reported SUPER SLOW search indexing...3 days in and my brain with 13,418 thoughts is at 53%.  Same Brain on the Mac version indexed in ~10 minutes.

Love to get some solid resolution on these issues...




Quote
Steeph
Have you tried increasing available memory for TB?
Search for "vmoptions" here.
PB user since 1998

Mind over matter?
I don't mind and it doesn't matter.
TB 8.0.2.1 Pro on Win10.1 Pro 64bit JVM 1.8.0-112
Quote
GRSaunders

Thanks...tried it.  No good though.  No change.  TheBrian is saying it is using about 65MB and has about 65MB available...that seems like a low amount of memory, especially because that option told it to use 320mb.

So, I completely uninstalled Java 7...then to test, I loaded TheBrain.   It loaded?  Maybe I'm misunderstanding something, but I thought TheBrain requires Java?  If I completely uninstalled it, what is it using?  Was it ever using the latest Java 7?  How can I be sure?

Either way, the search indexing is the same, about 1 file per minute.

Random TheBrain.exe has stopped errors on closing still persist.

Quote
Steeph
You must have another java installed. Somewhere.
Search for java.exe on all of your disks.
PB user since 1998

Mind over matter?
I don't mind and it doesn't matter.
TB 8.0.2.1 Pro on Win10.1 Pro 64bit JVM 1.8.0-112
Quote
bmac

When I had my issue with TheBrain on windows 8.1, simply uninstalling using the control panel did not work. I had to revert to the use of REVO, a very efficient uninstaller that searches for all registry entries entered as a result of a software installation. Once I uninstalled the brain using REVO, then reinstalled, everything worked fine. I did not have tofool around with anything related to Java.

Bill
customized Desktop PC (Haswell i7 4770 3.4 gHz with 32 GB RAM), Windows 10 Pro 64-bit, 256 GB SSD,  and a Microsoft Surface Pro 6, Windows 10, 512 GB SSD, 16 GB ram, i5
Quote
enkidu
why dontcha just use the zip file ? Forget installers/uninstallers (clean or otherwise)

also, are you sure there isn't a mismatch between 32- and 64-bit versions of TB and Java ?

cheers
enkidu
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software