PaulaO
I have the "bookmarklet" on my bar.
I open a site I want to save.
I click the bookmark.
Little window opens. Says "adding to inbox".
Then it says "not logged in".
Except I am.
Click the link to log in.
Log in. Leave that tab open.
Go to website tab.
Click bookmarklet.
Same thing.

The ONLY thing it will save are any TheBrain pages.

Ghostery is set to accept anything TheBrain sites want to do.
Cookie extension is set to keep all cookies from TheBrain's sites.
Firefox is up-to-date.
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
Harlan
Hello,

It sounds like a third party extension you have installed is preventing access to the session ID cookie that TheBrain.com uses to associate your BrainBox requests with your account. Please try disabling all extensions. Assuming that works, you can then turn them on until you find the culprit.
Regards,
-Harlan
Quote
PaulaO
That did not work. I had already tried disabling the typical suspects. Now I have all of them off and it still says I need to log in. I have tried it with several websites so it isn't the site I am trying to save.

I disabled, closed firefox, waited, reopened Firefox, same thing.
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
PaulaO
I just tried using the bookmarklet with Opera. Same problem.

Like the instructions say, I dragged the BrainBox link to the bar.

Opera has not extensions installed. I hate it and only use it for troubleshooting websites or stuff like this.
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
Harlan
Can you try with Chrome? (the bookmarklet will also work with chrome but you can try the Chrome extension also).
Regards,
-Harlan
Quote
PaulaO
Both the extension and the bookmarklet work with Chrome. So it isn't my computer at least. I did confirm my java was up-to-date.

So why won't it work with Firefox?
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
Harlan
FYI, TheBrain no longer uses Java so that is not related. We just released the BrainBox Firefox Add-on. Please give it a try.
Regards,
-Harlan
Quote
PaulaO
It still does not work on my PC. Even with all addons disabled.

It does, however, work on my partner's PC. Addons (she has just 2) left enabled.

We have the same anti-virus/firewall (bitdefender). I turned off the ransomware module and rebooted. Still doesn't work. Wants me to log in no matter what site I am trying to save.
I am also using a refreshed version of Firefox as of a few weeks ago. I do that once a year to clean up the clutter FF has.

This is something I would use A LOT and am disappointed it doesn't work for me.
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
Underdog
PaulaO, try creating a new Firefox profile and test BrainBox using the new profile. Also: what OS are you using?

- Michael
TheBrain 10.0.17.0 beta / 9.1.x / 8.0.2.1 / (PB) 6 || Win7

Quote
PaulaO
The new profile works. Why? No addons but BrainBox.

I use Win 10. It is up-to-date.
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
Underdog
Extensions are not the only things that can interfere with browser functionality. If disabling addons does not resolve a problem, the next suspect is user settings. By creating a new user profile, you now have default out-of-the-box settings for the new profile and, since BrainBox now works, one or more settings in your old user profile are disrupting BrainBox function, I suspect.

So what can you do now? Either stick with the new profile or compare the settings of the two profiles and make some good guesses which differences could result in the broken behavior (for example, cookie handling and security settings).

In the profile directory are two user pref files: prefs.js and user.js. You could compare these in each of the profiles (using a source code editor like Notepad++ with the compare plugin, for example). It may be enough just to check the Data Protection and Security Settings in about: preferences in each browser profile. I'd start with the Cookie handling section and work my way down.
 
 
 
 

- Michael
TheBrain 10.0.17.0 beta / 9.1.x / 8.0.2.1 / (PB) 6 || Win7

Quote
PaulaO
Looking at the .js files made my (physical) brain hurt. I only compared the prefs.js but really had no idea what I was looking for. I may try again later after the smoke in my head clears.

Looking through the security/privacy options, the only difference is the Tracking Protection. And of course no addons.
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
PaulaO
Okay. Found it. I had "Never" selected. Switched it to "Always". Now it is working. So very, very awesome.

Confirmed solution. Used the Tester profile and changed it to "Never". The Box kept asking me to log in.

cookies2.jpg
Take a deep breath and count to zen.

Spell checkers aren't worth shirt.

Writers and editors have their own demon. Typo is his mane.
Quote
Harlan
Thanks for helping out Michael!

Glad you got it sorted Paula and happy to hear you like it.
Regards,
-Harlan
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software