faithtime
Version 9.0.158.0

System Mac OS 10.12.3 (16D32)
 
1. If under Chinese Input Method mode, all keyboard shortcut failed to effect. 

2. English and Chinese content not right aligned.

Screen Shot 2017-03-22 at 13.08.39 copy.jpg 
Quote
mcaton
Faithtime,

Thank you for sharing these observations and the helpful screenshot.  I'll document your discoveries.

Thanks,
Matt
Quote
mcaton
Faithtime,

Trying to replicate the alignment issue you have pointed out.  Are you using Simplified or Traditional Chinese? I tested with Simplified and everything seems to line up fine. Please excuse my text, I'm just typing gibberish since I'm not familiar with the Chinese alphabet...

alignment.png 

Thank you,
Matt
Quote
faithtime
Hello Matt, I'm using Chinese Simplified 

I re-test with the text you typed, and the issue still exist. I'm using version 9.0.158.0

Screen Shot 2017-03-23 at 10.31.24.png  Screen Shot 2017-03-23 at 10.31.36.png  Screen Shot 2017-03-23 at 10.31.47.png 

I provided more screen shot,  and also I provide my test brz file.

hope this could be help.

Thanks

- P.DENG
Quote
faithtime
Hello Matt

I could figure out the reason caused the character align issue now.

The Font option under Brain Theme > Options, if I changed font to a Chinese specific font (for example: Heiti SC), all characters align the right way. 

If the font is set to Menlo / Helvetica ... characters got align problem.

Take a test [smile]

Could this bug be fixed in the future?

Thanks

- P.DENG
Quote
Harlan
Hello,

The font alignment is part of the font itself. Sorry, you'll have to choose a font that is properly setup.
Regards,
-Harlan
Quote
faithtime
OK, Got it.

Please fix the issue 1, then.

Thanks.
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software