kenosmith3

Hello,

I'm running Windows 7 64-bit with both 8.0.04 and 5 the application keeps failing to load a Brain file. I can create a new file but when it loads I still get the "loadLibrary Failed with error 126: The specified module could not be found"

I've tried un-installing both Java and the Brain without any luck.

I did notice in the output.log files the following errors related to a Path not being found.

Exception parsing brain info; file="null\Ken's Personal Brain.brain"
java.io.FileNotFoundException: C:\Program Files (x86)\TheBrain\null\Ken's Personal Brain.brain (The system cannot find the path specified)
 at java.io.FileInputStream.open(Native Method)
 at java.io.FileInputStream.<init>(Unknown Source)
 at java.io.FileInputStream.<init>(Unknown Source)
 at sun.net.www.protocol.file.FileURLConnection.connect(Unknown Source)
 at sun.net.www.protocol.file.FileURLConnection.getInputStream(Unknown Source)
 at org.apache.xerces.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
 at org.apache.xerces.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
 at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Sour

I would really like to get this fixed since I was just auto billed for $159.. BTW, where do I turn that off..

Thanks in advance.
Quote
pthompson
Ken,

Did you contact support directly on this issue yesterday. I remember seeing a similar issue yesterday, but don't remember if you were the one who reported. It'd be nice to know if this is an isolated issue with you or one that is occurring on multiple machines.
Quote
kenosmith3
Nope, I haven't contact support yet.. it's on my list if forums don't shed anything.. Do you want me to send you my output.log file?  My computer was recent re-imaged and rebuild not sure if it started with the re-image or with 8 upgrade. I guess I can try installing ver 7 if I can find a copy to see if it happens with it as well..

Thanks for your Help,

Ken
Quote
pthompson
Ken,

Yes, please, can you send your output.log to support@thebrain.com. Thank you.

The same thing occurred with someone else yesterday after a machine re-imaging so I suspect this has something to do with the issue.
Quote
kenosmith3

Would it be possible to have TheBrain use a different temp directory use other than the Temp folder under the users AppData? My company has prevent applications from being run under the user's Temp folder under AppData to try to prevent Cryptolocker from being Launched.

I'm not sure if that is my issue or not.. but it might be a clue towards the solution as 8.0.0.6 works fine on my non-corporate computer..

Thanks,

Ken
Quote
enkidu
Hello Ken

[ I'm not support, just a fellow user ]

your explalation is plausible, but in your output.log the error was in :

Quote:
C:\Program Files (x86)\TheBrain\null\Ken's Personal Brain.brain (The system cannot find the path specified)



not in the \Users\<whatever>\AppData directory.

I personally find it strange that your brains data files are under "

C:\Program Files (x86)\TheBrain"

That said, check output.log again to see what your Brain's settings are for these :

Quote:
Program Location = C:\bin\TheBrain8
Program Settings Location = C:\Users\enkidu\AppData\Roaming\TheBrain
Program Data Folder = C:\ProgramData\TheBrain
Cleaning temporary files from c:\temp\_system\TheBrain



then check your read/write rights for each, and/or eventually modify the directories in the settings file :

C:\Users\enkidu\AppData\Roaming\TheBrain\TheBrain8Preferences.xml

(or wherever it is in your case)

cheers
enkidu



Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software