doesn't work, keeps same password always. Very little feed back after reset. Page just redirects you to a login and only the original password works

given that you don't allow end to end encryption (like some services allow- as far as I know that's how your security works) not being able to change your password reliably is terrible 

I followed ( ) and using the forgot-password link and opening the email to reset the password, again, does not work

you should fix this or I'm out of paying you money for this service 

if it takes a while for the password to take effect, well that's not acceptable. If so it has to be at least documented that time frame. after 20 years of this application I would think you would get basic password security down

I know you guys can do it, so just do it

(again, I'm already disappointed that you don't have well documented and decent end to end encryption so users know the cloud sync data is useless to anyone who has access with out it e2e encryption- you're just hoping AWS is doing the right thing- never trust third parties)

Thanks for posting. I just ran through a few tests and the password reset functionality seemed to be working properly.  Let's review:

First, I noticed the link you posted had an extra space in the URL. Be sure you are navigating to:

After entering your email, you should click on the Send Email Button and the page should update with a message that says "Password reset instructions sent."

Your email link will forward you on to a page where you can enter your new password and confirm.  Again, the page should keep you informed and when clicking on the Reset Password button on this page, you should see "Your Password Has Been Reset"

This will change your password for logging into and version 9 of TheBrain. Is it possible that you are then trying to log into or version 8 of the desktop software? It is possible to have different passwords for v8 and v9. If you are trying to change your password for v8 or, you'll need to go to

Regarding our securities:
  • TheBrain 9 uses a completely different architecture from TheBrain 8 including improved security.
  • TheBrain 9 servers are hosted via Microsoft Azure and not AWS.
  • At present, there is no facility for accessing information even by administrators without the login information. Additionally, our services agreement does not permit us to access user data for any purpose beyond providing services to the user.
  • Passwords are salted and hashed and cannot be viewed by anyone.
  • File attachments and notes are encrypted using a 256-bit AES cipher (one of the strongest block ciphers available).

Thank you,
Not bad turn around time with the reply, so thanks!

Being an engineer myself I'm quite versed in my own PEBKAC issues (which are always many). I can assure you I used thebrain v9 reset. I can also assure you I tried several times with no avail across a couple of consecutive days. But! I can also tell you it worked today, same browser, same everything. So if you guys fixed something it worked (or I just got magically lucky today).

The one nitpick though is there was no error page or anything else to suggest that the password was reset. I simply got "password was reset" after following the documented process for v9 password reset.

also can you add https for the brain forum ?

in summary

  • I use brain v9
  • I had a small hiccup with the password reset not working for two days
  • It eventually worked
  • the moderators got back to me (above post) with a great reassuring post
  • The documented process for v9 forgot password said it completed the password change but clearly didn't (nitpick here that that's misleading)

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software