jotapa
Hi TB team,
these are some of the problems I see on version 9.0.94

Slow Notes Editor
In version 8, I was able to use the TB to take notes during an online meeting, capturing several screenshots from online demos, and pasting them into the notes. It wasn't good (far from it) and I was very happy when I saw a new Notes Editor, but it usually worked.

We can't yet say the same about the new one. The version 9 editor becomes painfully slow when I start pasting images. With only 3 you can see it is slower, with 5 or 6 images it becomes impossible to write because the text takes 10 seconds to show up after you type a word.

Coupled with the fact that the Editor is not (yet) able to render JPG or PNG images (I have to paste BMP) it makes me regret the old editor is gone...

You need to fix the editor TB team. And not just make it work. It needs to be really good! That is one of the most important user experience components in the brain, and one that users can easily compare with other tools. 

This is one of those make or break situations. If the Notes Editor is not good and fast enough - including supporting images and other complex content (like tables) on reasonably long texts (at least 15 pages)... there is no chance I can use this software.

Preview Button Problems
The preview button continues to show up at the bottom of the window - unnecessary mouse travel and bad UI choice. Also, it does not show as it should - it's 80% hidden:
Preview Button.png 
We don't need a mega-super-jumbo icon to understand there is a PowerPoint file attached. Can you make it smaller, please, and move the Preview button/icon up to the TAB, next to OPEN FILE? That would be great.

Small Preview Windows 
When I press the button to preview, this is what I get - a tiny window completely misplaced:
Small Preview.png 

Same thing happens with a Word file Preview:
Small preview Word.png 
The small box with "This is a test..." is the word document preview.

------------------------------------------------------------------------------------------------

Looking forward to seeing this fixed.

Thanks,
Joao
Quote
pthompson
jotapa wrote:
With only 3 you can see it is slower, with 5 or 6 images it becomes impossible to write because the text takes 10 seconds to show up after you type a word.


I have definitely not seen this. We are working on a Brain internally with multiple Thoughts that contain lots of images and we are never seeing any slowing. Does this occur with every Brain for you? If so, can you please share the types and size of images you are inserting? Any additional information you can share will help us troubleshoot this issue. 

jotapa wrote:

Coupled with the fact that the Editor is not (yet) able to render JPG or PNG images (I have to paste BMP) it makes me regret the old editor is gone... 


Again, I am not sure what you mean here.... JPG and PNG images can be added to Notes.

jotapa wrote:

The preview button continues to show up at the bottom of the window - unnecessary mouse travel and bad UI choice. Also, it does not show as it should - it's 80% hidden:


This has been noted before and has already beed documented. Thanks.

jotapa wrote:

When I press the button to preview, this is what I get - a tiny window completely misplaced:  

Same thing happens with a Word file Preview:
  
The small box with "This is a test..." is the word document preview.


The preview functionality is still a work in progress. Thanks for your thoughts.
Quote
perry
pthompson wrote:

Again, I am not sure what you mean here.... JPG and PNG images can be added to Notes.


I wonder if it's inserting from Clipboard that's the issue? paste-image-from-clipboard-to-notes-not-working

Quote
pthompson
perry,

That is a great theory. I would like to know that as well. 
Quote
jotapa
Answering the previous questions...

I had the problem with a 700+ thoughts v8 Brain imported to v9 a couple of months ago. When I tested this, last Thursday, it happened repeatedly. I closed other applications, restarted the PC, checked for other running applications (like anti-virus) and there was no doubt - The Brain was painfully slow.

Today, doing exactly the same thing, it's working fine and I cannot replicate the problem... I feel frustrated! I know it must be an issue with TB because other applications were working when I first had the problem, but I have no way to demonstrate what the problem is.

Will have to keep an eye on this and if it happens again, record a video so you can see it too.

About the BMP vs PNG/JGP issue - yes, the problem happens when I capture screenshots and Paste then into TB. The problem has been documented before and is not solved yet.
Quote
pthompson
Thanks for the update jotapa. Keep us updated if you are able to replicate the issue and provide us steps to recreate it.
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software