How do I get the little icon to appear before a node that indicates the node is linked to a URL?
When you initially add a URL into the V8 web brain, the web site may already have a favicon image attached which will show up by default as the thought icon.

You can test this by adding Google.com to one of your thoughts:
> After logging into your web brain account, create a new note.
> Select "Edit" the new note window.
> Select "Add Attachment" ==> Select "Add a Link"
> When you save your edits, Google's favicon should show up automatically as the thought icon.

However, some sites don't have a favicon, or the one they do have may not show up.

In either case, if you want to add your own icon, I think there's only one way to do this in the web brain: you can add an existing thought type to which an icon has already been attached when the thought type was originally created in your desktop brain.
> Right click on an existing thought in the web brain.
> Select from your existing thought types to which icons have already been attached.

if I'm missing any other options for adding an icon to a thought with a URL in the V8 web brain, hopefully someone will let us know.

Also, FWIW, I just now checked 3 of my own V8 web brains, and many of the thought icons are currently missing from one of my web brains. I'm not sure why when they seem to be working in my other V8 web brains, and it looks like this might be a bug.

In light of this, I'm wondering if you might have also run into a problem with any pre-existing (or newly attached) thought icons not showing up in the web brain?

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software