korm
I wanted to refresh all the attachments for v9 -- i.e. the contents of

~/.TheBrain/v9/Templates/System

I deleted that folder and I deleted TheBrain 9 from Applications.   I downloaded 

http://www.thebrain.com/products/thebrain/thebrain9

Opened the DMG and dragged to Applications.   I had assumed that installing a preview version would also install the system attachments.

No.

I could go into

/Applications/TheBrain 9.app/Contents/MonoBundle/Templates.zip

and grab them from there -- but I wanted to try doing this the "official" way.

Any suggestions?  Should I delete ~/.TheBrain/v9/* and start over?




Quote
mcaton
Paul,

You should really only add new File Templates through the application. The TEMPLATES button in the Add Attachment window will direct you to the USER templates folder.  This is where you can add your own custom or blank File Templates for anything that TheBrain did not automatically add to your list.  Manually modifying the System directory is not recommended.

Reinstalling the app as you have mentioned should re-populate the System directory, but that doesn't mean you'll have each of these items as an available Template from within the app - only files that TheBrain recognizes as being installed.

Thank you,
Matt
Quote
korm
Matt, you might want to re-read what I posted.  I know how to add attachments of my own -- that not what I asked though.

As I wrote:

Quote:
I wanted to refresh all the attachments for v9 -- i.e. the contents of

~/.TheBrain/v9/Templates/System



and I then explained my steps.

"Matt" wrote:
Reinstalling the app as you have mentioned should re-populate the System directory,

and I explained that this is not the case -- I explained that I re-installed v9, and where I obtained it, and that the system template directory was not repopulated.

But thanks for your time.
Quote
mcaton
Sorry for any confusion.  I wasn't clear that re-installing the application had actually left the System folder blank.

Yes, you can extract the contents of Templates.zip into your System folder to re-populate it.

I'll do some additional testing to see if we can replicate and discover why it wasn't repopulated after a clean install.

Thank you,
Matt
Quote
korm
Thanks.

I can confirm that when 9.0.107.0 is installed with a clean install that it does not install System templates.

I also found that if  ~/.TheBrain/v9 is deleted before 9.0.107.0 is installed, that that version does not create ~/.TheBrain/v9.

In fact, if that directory is missing then v9 merely bounces in the Dock and then quits.  It never launches.   There is something defective in the installation process.
Quote
pthompson
korm wrote:

I also found that if  ~/.TheBrain/v9 is deleted before 9.0.107.0 is installed, that that version does not create ~/.TheBrain/v9.

In fact, if that directory is missing then v9 merely bounces in the Dock and then quits.  It never launches.   There is something defective in the installation process.


This is a known issue that will be fixed in the next update.
Quote
korm
Patrick, good to know. Thanks.  Settled.
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software