EaterOfFromage
Hey,

Yesterday, I reinstalled OS X 10.7 Lion. When I tried to open PersonalBrain, i got this error:

"IO Exception: java.io.FileNotFoundException: Q:  ... brain.lock.db(Permission denied); Q: ... brain.lock.db[90031-145]."

It then says data to be recovered from the continuous backup service.  But, this returns a generic error message, and my brain does not load.

This guy had a similar problem in the past, but a slightly different error message:


A few differences: He was on a remote windows server, I'm on a mac; he got Access is Denied instead of Permission Denied, and a different error number; and, probably most importantly, I have no brain.lock.db files. For any of my brains. As far back as I have backups (almost a year ago).

As far as I can tell I don't have any problems with permissions, but maybe I'm not looking in the right places?

Cheers!
Quote
EaterOfFromage
Alright, I guess I should have tried a bit harder to fix this. But in any case, I'll explain what I did so that others who come upon this problem will have a solution handy.

What happened was that when I was reinstalling Lion, I didn't restore from time machine, I picked individual folders to restore. One of those was Documents, where my brains are stored. In overwriting Documents, I had to deal with a lot of permissions issues, which I thought I had sorted out. However, for some reason, the brain_db folder only had read access. Simply getting the info for the folder in the context menu, then changing the permission of "staff" to read/write (I don't know why staff...) fixed the issue.

Best of luck!
Quote
Tracy
Thanks for providing these additional details! Tracy
Tracy Barr
TheBrain Technologies
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software