tshanno
Hi.

I've tried this with both Gnome and KDE. In neither case does the Linux version recognize the OS default browser setting. Instead, Firefox is always used.

Under KDE:
1) Go to "System Settings"
2) Go to "Default Applications"
3) Click "Web Browser" in panel on left.
4) Under "Default Component" choose, "in the following browser" and (for instance) choose "google-chrome" from the dialog.
5) Close "Default Applications:
6) Browse a link which is attached to a thought.

The link opens in FireFox.

Tom S.
OSX & J-1.6.0_17
KUbuntu 9.10
PB 5.5.2.2
KDE 4.3.2 & J-1.6.0_16
Quote
tcahill
Hm,, I thought this used to be configurable in Preferences.

For KDE4 open "Personal Settings/Configure Desktop" (on some systems this might be called "Desktop Settings/Personalised Settings").

You will want to be in the icon view rather than the classic KDE control panel view.

Open Default Applications, select Web Browser and change.

Cheers.
Be vewy quiet. I'm hunting wabbit.
Quote
tshanno
Thanks for the response.

I don't see any of this (or at least can't find it).  I do a search for Personal Settings and don't get anything.  I'm guessing, its because I'm using Kubuntu, which I'm sure changed the configuration settings to better match the other distributions.  In any case, the setting appears to be in the System Settings on my desktop and it works for other applications.

I'm thinking that the different environments and lack of standardization in Linux is working against us, here.  Probably that's why drag and drop doesn't work.

In any case, perhaps a reasonable solution would be to put it in as an option in the Preferences in PersonalBrain.  That would make it desktop (and OS) independent.

Tom S.
OSX & J-1.6.0_17
KUbuntu 9.10
PB 5.5.2.2
KDE 4.3.2 & J-1.6.0_16
Quote
tcahill
tshanno wrote:
I don't see any of this (or at least can't find it).


I just realized that you noted you are running KDE 4.2.2. I'm using 4.3.1. Perhaps that is why you are not finding it.


Be vewy quiet. I'm hunting wabbit.
Quote
tshanno
Ah.  Could be.  Ubuntu 9.10 is due out any time.  I'm sure the upgrade will include the KDE desktop.  Does the browser that PB uses change when you change the setting in KDE 4.3.1 then?

Tom

OSX & J-1.6.0_17
KUbuntu 9.10
PB 5.5.2.2
KDE 4.3.2 & J-1.6.0_16
Quote
tcahill
tshanno wrote:
Ah.  Could be.  Ubuntu 9.10 is due out any time.  I'm sure the upgrade will include the KDE desktop.  Does the browser that PB uses change when you change the setting in KDE 4.3.1 then?

Tom



Yes. But stay tuned for some great news about drag and drop. I've got it working (crosses fingers)

check it out here:   http://forums.thebrain.com/post?id=3723369
Be vewy quiet. I'm hunting wabbit.
Quote
jostber
To select which browser PB uses to open web sites, you can edit this file:

~/PersonalBrain/res/DefaultUnixCommands.properties

Go to the line "html" at the bottom and put your preferred browser in front of the other choices. Shut down PB before this change, or the file will be overwritten.

The quick way in vim:

vim ~/PersonalBrain/res/DefaultUnixCommands.properties

then this command:

:%s/html=firefox/html=google-chrome,firefox/g  

and this to save and close:

:wq

Then start PB and it should work.





TheBrain 8.0.2.2 Slackware 14.2 KDE 4.10.3 Java 1.8 / (Windows 7)
Quote
tshanno
Thanks for this suggestion.  It  very obviously should work.  Yet for some reason which I can't fathom, I've been unable to get it to do so.

Its a simple modification.  Here's the original lines from the configuration file in my installation directory:

html=firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

htm=firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

and here are the altered lines:

html=google-chrome,firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

htm=google-chrome,firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

The only thing I can figure is that I'm editing the wrong file.  But I can't find another version in my home directory or any of the subdirectories so I don't know...

Tom

OSX & J-1.6.0_17
KUbuntu 9.10
PB 5.5.2.2
KDE 4.3.2 & J-1.6.0_16
Quote
jostber
tshanno wrote:
Thanks for this suggestion.  It  very obviously should work.  Yet for some reason which I can't fathom, I've been unable to get it to do so.

Its a simple modification.  Here's the original lines from the configuration file in my installation directory:

html=firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

htm=firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

and here are the altered lines:

html=google-chrome,firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

htm=google-chrome,firefox,opera,konqueror,epiphany,quanta,mozilla,netscape

The only thing I can figure is that I'm editing the wrong file.  But I can't find another version in my home directory or any of the subdirectories so I don't know...

Tom



It's important that you edit the html lines at the end of the file to make it work. Can you check that?


TheBrain 8.0.2.2 Slackware 14.2 KDE 4.10.3 Java 1.8 / (Windows 7)
Quote
tshanno
jostber wrote:
It's important that you edit the html lines at the end of the file to make it work. Can you check that?


(slapping forehead) Doh!

I swear I searched that file for "htm". It appears that there were four lines, not two, but the second pair looked so much like the first, I assumed they were the same lines hitting more than once on the search.

In any case, I corrected the ones at the *bottom*, too, and you are correct. Works very well.

Thanks, again.

Tom
OSX & J-1.6.0_17
KUbuntu 9.10
PB 5.5.2.2
KDE 4.3.2 & J-1.6.0_16
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software