Pucs
Hi there, 

I am using TheBrain(for Mac) 8.0.0.7, here's the problem:

I've saved lots of large scale images(eg. 3800px x 3800px), each image in one thought, and all these thoughts are children of one same main thought. 

Every time I active the main thought, the thoughts under it start loading their thought icons(which is each image's thumbnail), and this process costs plenty time and sometimes it cause the application halt.

I've checked the preferences and found out an option under Look & Feel panel named "Load thumbnails for large images", but no matter it was checked or not, the "loading thought icon" process still stands. I wonder any way could improve this situation but without decreasing maximum child columns number?

Thanks for any tips.
Quote
pthompson
Pucs,

How many of these large images do you have attached? I'm assuming it's the large images that is causing the issue but I will have to test this on my end.
Quote
Pucs
pthompson wrote:
Pucs,

How many of these large images do you have attached? I'm assuming it's the large images that is causing the issue but I will have to test this on my end.


Pthompson, there're 4 columns and 12 thoughts under each column(in normal view), each thought has 1 image. In my case, there're over 900 such thoughts under one parent thought, so that I can barely view them in expanded view or the Brain will easily halt down.
Quote
mcaton
Sounds like you may need to increase your Java Memory that TheBrain is utilizing.

It is possible to increase TheBrain's memory allocation by editing the vmoptions file.

By default, TheBrain uses a maximum of 192 MB. This is usually enough but for some operations there may be an issue with running out of heap space.

The example below raises the max to 320 MB, but the number can be higher if needed.

1. Close TheBrain.

2. Create a text file and put the following content into it:

-Xmx320m

Make sure there is a linefeed (Enter) at the of the text. Save this file and name it TheBrain.vmoptions in TheBrain program folder: (Program Files > TheBrain) or (Program Files (x86) > TheBrain).

3. Restart TheBrain.

Thanks,
Matt

Quote
mcaton
Ah!!! I just noticed you are on a Mac.  New instructions:

The instructions for increasing the VM on a Mac is a little more complex.  First, make sure that you have downloaded the special installation for Java 7 from our download page (www.thebrain.com/download).  You'll see the "Alternate download for Java 7" link.  Don't just click on the big DOWNLOAD button.

Next the Xmx settings are inside the application bundle (show package contents) in a file called Info.plist.  Open this in Wordpad and just to a quick search for Xmx to find the settings.  Again, you can fiddle with the settings a bit to find out what will work best for you.

Thanks,
Matt

Quote
Pucs

thanks Matt!

This really works. I've noticed that even the normal Mac version(directly downloaded from the big DOWNLOAD button) also could be done that way by following step:

1. right-click on the app, select "show package contents"
2. open '\contents\Info.plist' by any kind of wordpad app
3. find strings below:

Quote:
<key>VMOptions</key>
<string>-Xmx192m -Xms35m</string><!-- I4J_INSERT_VMOPTIONS -->

4. increase 192 in "-Xmx192m" to a larger number. For me, 1024m works pretty smoothly.
5. relaunch theBrain, the new memory setting will be applied.

theBrainVM-1.jpg theBrainVM-2.jpg theBrainVM-3.jpg theBrainVM-4.jpg theBrainVM-5.jpg 

However, not sure I'll need to adjust this setting every time after updating the app, hopefully there's an in-app setting under application preferences and the setting would be kept over different app versions. Hope your genius designers and engineers will consider this feature in future versions [biggrin]

Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software