tomcal123 Show full post »
russnh
Has this problem re-appeared? I know for certain that one of my notes has the name "Nixon" in it and nowhere else and yet when I search for it, nothing is found:

notenotfound.JPG 

The thought itself is called "Last update" to avoid confusion. I also clicked the "Create an orphan Thought using the text in the search box" to search for that and it was found, but not when I forgot the thought and wanted to find the text in the notes only.

I hope I'm not missing something obvious!

Thanks

Log file attached.
Brain 9.0.224.0
Windows 7 Enterprise SP1
Quote
zenrain
What happens when you try to search using Windows in that directory?
macOS 10.14.6
TheBrain 11.0.119
Quote
russnh
It finds the note and its contents...
Quote
zenrain
Ok, I would do a search on this forum, I seem to remember something similar reported and it being related to the root folder it was contained in. 
If you don't find that, run the search and submit the output.log to support immediately after it's attempted to do the search and they can research further. [smile]
macOS 10.14.6
TheBrain 11.0.119
Quote
russnh
Thanks!
Quote
russnh
It seems a little inconsistent. This happened on two different PCs, but I've come back to one of them after restarting it and now the search works in notes as expected. Odd!
Quote
shatcher
Russ,

Do you mean that you forgot the name of the Thought within your Brain, or that you clicked the "Forget Thought" button, then searched for the note? This second option would not show up in search. If you have a Thought that was not removed from your Brain and can't find that in search, then we will need to look at that issue. Have you sent an email and your Output.log to support@thebrain.com ?

Cheers, Sean
Quote
russnh
Hi Sean, I mean that I deliberately clicked "Forget thought" to see what would happen, fully expecting it to not show up in a search - as you say it shouldn't - and it didn't appear in search. That's obviously the correct behaviour. However, if I put that same text into another thought's notes, a search for the text in the note wouldn't find the thought with that text. Since doing that test and restarting the brain several times (and on different computers) it fails to bring up the problem again, so I can't repeat it. One of those elusive bugs that you might spend a lot of time chasing to no avail...

I've not sent an email to support yet, but if the problem recurs, I will do so with the output.log file attached.

Thanks,
Russ
Quote
mcaton
Russ,

Thanks for the update.  We have not yet been able to replicate either, but will continue testing.

Thank you,
Matt
Quote
mcaton
Russ,

Wouldn't you know it.  Soon after I post "we have not been able to replicate..." I replicate!  Documenting for further review.

Thanks,
Matt
Quote
russnh
A slippery fish after all! Thanks for looking into it.
Quote
Underdog
FYI: I have an open ticket (#62201) on this issue in the latest stable build 9.0.263.0. (Log file is being analyzed.)
 NoNotesSearchResults.png 
I just made a new Brain with a single thought and one line of text in the Notes. The search fails to find any text in the Notes.

- Michael
TheBrain 10.0.17.0 beta / 9.1.x / 8.0.2.1 / (PB) 6 || Win7

Quote
mcaton
Michael,

I saw your note in support and the engineering team is taking a closer look.  Search is still working fine in my tests.  Any other Win7 users out there with a search issue in 9.0.263?  

Thank you,
Matt
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software