mctrexler Show full post »
jpbarragan

metta wrote:

In the meantime, did you confirm the data on the affected thought was permanently lost by checking the contents of the notes.html file? And did you share a copy of the notes.html file with support?


Yes Metta, I did confirm the issue in the html contents in the note's folder. I will update my ticket with this contents.

Thanks for your interest and advise.

Juan Pablo Barragán
Odoo Concept
jpbarragan@odooconcept.com
Quote
dlorde
I've had both these problems too - notes appearing to be overwritten because note content from a different thought is displayed, and note content being replaced with content fro a different note. 

The refresh problem seems to be more common than the replacement problem, and I don't think I've seen the replacement problem in v.10 yet.

These days, if I see the wrong note displayed after some action(s), I click away from the thought then back to it, and if it's still not right, I 'undo' until things are back to normal. I just hope that batch activities don't cause these problems...
Quote
Harlan
I am in communication with Juan directly over our support channel now. For those others that are reading here on the forums, here are the relevant details that I have shared with him there:

One of our senior engineers has reviewed the logs and the circumstances of this case in detail and I went over it with him. While we are not sure what specifically happened in this case, we will be aggressively pursuing improvements to the way the loading and saving of notes happens to further harden against this problem.

We made a change in May 2018 which we believed eradicated this problem. Prior to that change there was a way to cause one note to overwrite the content of another note that we were able to reproduce. This solution was rolled out in version 9.1.4. Since then we have not been able to reproduce the issue and incidents of user reports of the issue have become very rare. In most cases, we have been able to verify that these reports were either a case of "stuck" notes that are not really overwritten or they were cases of the same issue that was solved with 9.1.4 but which happened prior to upgrading to 9.1.4 and were not discovered until later.

In this case and one other that I am aware of it appears that something else is leading to the same result. We believe the root cause is related to the way notes are saved and loaded via an embedded browser, which leads to complexities with regard to multiple threads. In short, the May 2018 fix attempted to ties the ID of the note (which determines where it gets saved) directly to the content of the note itself. I say attempts because it appear to have failed to do so in this case. We will be redesigning and reimplementing this area of the code to make it simpler and more reliable.

Regards,
-Harlan
Quote
metta
Thank you very much for this update, Harlan

I appreciate the status report, and I'm very grateful for all the effort being made to resolve this difficult issue.
Quote
MalecJan
If there are other victims, I would be interested in some information from them, if we could see any possibly helpful regularities:
• How frequently and how were Notes of the "invasive" Thought edited.
• When were they created and when were they recently edited (interested if it was around time of actual data loss)
• The same data for Notes of "affected" Thought.
• If "invasive" and "affected" Thoughts are (can be) activated consecutively without intermediate Thoughts, especially in time around having focus in Notes.
• If Notes of "invasive" Thoughts were moved from original location or if only copy was created.
• How long were the Notes of "invasive" Thought (how many lines, characters).
• Which part of "invasive" Notes was moved/copied (whole, only beginning, end, ...)
• What you consider relevant
Quote
MalecJan
Details of data loss in my case and related thoughts:
Notes loss (overwriting) observed approximately 2x/year, since 2017 (2 months after I started using TheBrain, version 9) till 2019-02-14 so far (TheBrain 10, on Windows 7).
Issue observed repeatedly only for few frequently (daily) modified Thoughts ("Do Today", ...), with Notes over 30 lines long. I have no reliable observation of this happening to other, less frequently accessed Notes.
In last occurrence, long Notes were replaced by whole one-line-long Notes, which were copied from another existing Thought (Notes were preserved also in original location, not moved).
I noticed problem few minutes after editing one of involved Thoughts. Both involved Thoughts were pinned, frequently activated consecutively and Notes of affected thought were frequently edited.
I frequently activate pinned Thoughts by F1,...,F8 keys without any modifier ... Shortcuts created by exporting TheBrain shortcuts, manually removing modifiers and importing back.
I do not remember if in other Notes-loss occurrences, Notes became completely blank or if they were replaced by something.

I was dragging frequently parts of affected Notes up/down within Notes (ordering, prioritization, ...). Each dragging causes new span tags with style="font-size: 11.9747px;" to be added into Notes.html around dragged text (in 10.0.45.0 and previous versions). I do not know if amount of span tags could exceed capability of html editor and produce loss of Notes.
Dragging near the time of another Thought activation can cause part of Notes to be copied from one Thought to another as I reported to Support #67108 2019-03-17.
Since last issue I started to utilize dot convention to order child thoughts instead. I would like to know if there is some limit for history of changes for each thought. Currently it already takes a lot of time to display history of some busy thoughts. Potential of data loss on thoughts (graph) level worries me much more than on Notes level.

Potentially related issues:

Notes jump down/up due to Notes menu bar when moving focus between Plex/Notes.
In case of some accidental combinations of long/short clicks, some text gets often selected and I suspect, other unexpected behavior (dragging, ...) might happen. Especially around time when another Thought is activated when display of Notes area is not synchronized with internal activities so user does not see what is going on inside machine.
Solutions suggested -->here might partially help in such cases.

Related issue: http://forums.thebrain.com/post/deleted-notes-not-being-saved-10091815

In 2017 in version 9, I have experienced following related problems with Notes (not reported yet):
• Cursor sometimes suddenly jumped from the end of line to the beginning of line during editation.
• I have written some text to the end of Notes and from clipboard I pasted link to one website. Immediately, all text in Notes of this Thought disappeared. I tried to open Thought folder but there was only empty file Notes.html. This happened only once AFAIK.
Quote
metta
Good questions, Jan.

I haven't had an issue with overwritten notes in a long while, but I also have not been using TB10 very much at all -- so I don't have anything recent to report. This also means my memories of the details are now pretty foggy, as well.

However, I can share a few observations:
  • Since I began testing TB9|10 back in October 2017, I experienced the "stuck" (overwritten) note on multiple occasions, with more than 8 help desk tickets submitted on this issue -- including one strange instance in November of last year in which an edited thought in the web client was overwritten by the Home thought when I navigated from the edited thought to the Home thought in the web client. (I have since stopped editing thoughts in the web client for this very reason.)
  • More recently the issue in the desktop seemed to be a problem with the note not refreshing properly, rather than being actually overwritten.
  • As I recall, in most cases the "invasive" thought was not new and had not be recently edited.
  • The thoughts affected were usually closed located in TB (often parent/children I think). However, in many (if not all) cases, I think the invasive thought may not have been recently activated, so I have no idea why it was involved with the affected note.
  • These problems always occurred immediately after a note had been edited -- and I never found an overwritten note elsewhere in TB where thoughts had not been recently edited.
  • I had not ever noticed if there was a pattern in the length of the notes, but my best guess is that most of the affected notes were more than a line or two -- and the invasive notes were, as I recall, nearly always relatively long.
  • The invasive thoughts were always copied (never moved) in their entirety.
  • In no instances did the existing content in an affected note simply disappear. It was always overwritten by the entire content of another note.
  • I never noticed any issues being related to dragging/dropping content within the notes. However, I suspect both issues may have been related to editing existing notes rather than editing new notes.
  • I never saw a connected with pinned notes.
  • There have a been lots of other problems with the performance and behavior of notes editor, but I never saw a connection (either direct or indirect) between any of these other note editor issues and the overwritten (stuck) note issue.
I don't know if this additional information is helpful, but I share it for whatever it might be worth.

Please note that I think the observations above apply in both cases: where notes were previously overwritten, and more recently when thoughts have simply had problems refreshing.
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Circle Us on Google+  Google         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software