jotapa
Pasting an image from the clipboard to the notes box is not working for me. It creates an empty rectangle but the image cannot be seen.

Is this a bug or is the functionality still being implemented on version 9?

Thx
Joao
Quote
perry
Works for images copied from TB8, but not from some other software.

Just tried with system viewer and it pasted ok.

I'm on Windows10 too.
Quote
jotapa
I use a tool called Greenshot to take screenshots during online meetings and, before, would simply Paste the screenshot capture into notes in TB8. It is not working when I paste to TB9 instead.
Quote
perry
jotapa wrote:
I use a tool called Greenshot to take screenshots during online meetings and, before, would simply Paste the screenshot capture into notes in TB8. It is not working when I paste to TB9 instead.


Funny: I use ScreenShot Captor, and it's the software that failed on my system [smile]
Quote
zenrain
Ok, so to clarify the issue, does TheBrain 9 work if you use the OS to take a screenshot, but not the third party software? 

Second, have you tried shutting down and re-starting TheBrain 9 after pasting?
It's a silly question, but I had a similar issue when I first started testing on OS X and it didn't seem to paste images. However, after restarting TheBrain the images appeared. If this works, it's still an issue, but it will give them more clues as to what is occurring (in my case, it worked fine after that, I was never able to recreate, annoying...).

You might also send them a copy of the output.log after trying to paste an image.
macOS 10.14.6
TheBrain 11.0.119
Quote
jotapa
The screen capture tool is working perfectly - I can capture to Word and even to TB8.

I tried closing and open TB9 after pasting an image and I still don't see it. There is a rectangle in the notes box that can be selected but it's blank.
Quote
pthompson
jotapa,

As zenrain hinted at. Have you tried copying and pasting using the system's copy and paste instead of the third party software? Does this work for you? If this is something that is only occurring when you are using Greenshot, then it is something we will look into but it would be helpful to know this so we can better narrow down the issue. 
Quote
jotapa
Ran a few tests to diagnose the problem:
- Used my current screen capture tool - Greenshot and captured part of the screen. When I try to paste into TB9, I get a blank rectangle - no image. Instead of TB, I pasted into PowerPoint - the image is perfect, which means that my old tool (Greenshot) works.

Now the funny thing:
- In PowerPoint, I selected and copied the image that had been pasted. Tried to paste it into TB9 again, and this time it works. Meaning, when I select an image object in PowerPoint (even if it is a screenshot capture), it can be pasted to TB9.

Tried the other tool that was mentioned - Screenshot Captor and have the same problem - not able to paste captured images from screen capture tools - only get an empty/blank rectangle.

Appreciate the TB9 team help.
Joao


Quote
mcaton
jotapa,

This is very helpful information.  Thank you for the update and we'll document the issue with Greenshot.

Thank you,
Matt
Quote
perry
mcaton wrote:

Thank you for the update and we'll document the issue with Greenshot.


Well, not just Greenshot, images from ScreenShot Captor failed too (interestingly they paste into TB8 but leave a blank bounding box in TB9).

Other programmes that fail when the image is copied to the System Clipboard:
  • IrfanView
  • GIMP
  • MS Paint
  • MS Edge
  • Google Earth
  • SageLight (this was odd: the image pasted was not the image on the clipboard which pasted into MS Word for example)
Programmes that worked:
  • Picasa
  • Picasa Photo Viewer
  • MS Photos
  • XYPlorer
  • VLC MediaPlayer
  • MS Word
  • Chrome
  • PDF-XChange
  • Vivaldi
  • MS Snipping Tool
So, a pretty mixed bag there... but however TB9 is accessing the Clipboard misses the mark on nearly half occasions (that other software has no issues with -- i.e. can paste into other application when it fails in TB9)

Maybe in the different formats being stored? I should get a clipboard viewer and check...

Quote
mcaton
Perry,

Thanks for the complete list.  I'm documenting the full set for review.

Matt
Quote
perry
mcaton wrote:
Thanks for the complete list.


[wink] I just wanted to show it was not isolated to a few programmes... and these were just the easy programmes to get to on my system.
Quote
jotapa
Just discovered what the problem is and how to fix it: the Clipboard image format is the problem. 

Using my favorite software for screenshot capture, I configured the standard format used to capture screenshots to the clipboard:

     - HTML, HTML with Inline, bitmap. All of these work - bitmap is the best one because it retains the image size.

     - Tried Device Independent and PNG: image paste to TB does not work.

If you want to replicate this, download Greenshot, configure to clipboard capture and select the image format on the Expert tab.

Hope this helps fix the bug, TB team.
Quote
mcaton
Joao,

I've downloaded Greenshot and confirmed.  I'll update the engineering report of this issue.

Thanks,
Matt
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software