advisors
Hi there,

I searched the forums for a solution, could not find one.
All other threads are closed for comments, so I had to create a new one.

I'm at work, can't connect to my Brain (from PB, webbrain works fine).

I've tried various proxy configs, without success.

By searching the forums I found out this seems to be an old known problem.
Unless I missed THE thread solving it ?

TIA,

Here's an extract from my log:

43013 [AWT-EventQueue-1] INFO com.thebrain.personal.a.d.j - Proxy set to true http://proxy.etat-ge.ch:8008/proxy.pac:8080 userDomain: :kappr
43013 [AWT-EventQueue-1] INFO com.thebrain.personal.a.d.j - Read System default proxies........
43013 [AWT-EventQueue-1] INFO com.thebrain.personal.a.d.j - Proxy information set
54768 [AWT-EventQueue-1] ERROR com.thebrain.personal.a.c.p - Error validating WebBrain user: http://proxy.etat-ge.ch:8008/proxy.pac

And here are the related threads I found:

 How to use a Proxy
1 2 3
ZippoTheBrain 7 Beta3,98344April 11, 2012
by HeinrichUnger
 
 Proxy setting for PB6 with webbrain sync
1 2
sjeekePersonalBrain 6.0 Beta3,23715July 6, 2010
by Harlan
 
 The brain 7.0.4.0 proxy issuesXOverIssues1,37511June 22, 2012
by rubens
 
 Using theBrain with proxyVisnetTheBrain 8 Beta8185Nov 18, 2013
by pthompson
 
 How to set proxy server for PB?DryopithecusTheBrain How To1,5194Sept 11, 2007
by Dryopithecus
 
 Personal Brain and proxiesEngelenHIssues9854Jan 9, 2008
by TheSeparator
 
 Proxy questions censored?VisnetIssues1,0054Dec 21, 2012
by Visnet
 
 TB7 Hanging at Splash ScreenSimonTheBrain 7 Beta6054Feb 27, 2012
by HeinrichUnger
 
 Missing Favicons 5.0.2.6shinyplasticIssues8222April 1, 2009
by SamCox
 
 Proxy supportbenti01Feature Suggestions8460Oct 30, 2007
by benti01
 
 Status of proxy functionality?benti01PersonalBrain 4.5 Beta Archive2,2250July 23, 2008
by benti01
 
 Outstanding Issues with 4.2 Beta?
1 2 3
HarlanPersonalBrain 4.5 Beta Archive2,90132April 24, 2008
by krypticide
 
 Cannot connect to ServerJoachimCloud Services Issues1,4142Oct 29, 2012
by Joachim
 
 Proxy setting doesn't seem to work
Quote
Visnet
I do not think you missed THE thread.
If you are able to use Java 6.21 the brain will be able to use the proxy configuration.

Once you move on to Java 7 or 8, no go for proxy environments. Been dragging this issue on this board as well with incidents for two years and gave up when support again asked for logs. With every incident I delivered logs, nothing to be found in the log... Funny part: incidents where not to be found either after a while....

I wish the development team would do a test with proxy enabled....

Wim

Quote
advisors
tx Wim for your input.

Wait and see ...
Quote
shinyplastic
Hi All,

Have spent many days solving the proxy problem, but can confirm *depending on the proxy configuration* the proxy definitely works (since about Brain 7.1) in Java 7 and 8.

Just a few notes,
- verify it works not on a proxy [smile]
- instead of a .pac you need to find the IP / name of the proxy server and port
- verify this works with ping
- verify this works in a browser Firefox / Chrome
- try these setting in The Brain
- if it works consider using Cntlm to tunnel all your programs to localhost: port
- then you can set / change all your programs with one .bat file (on / off the proxy network)

Feel free to post any information if you want some help.

And of course the Brain support email are usually pretty helpful!

Cheers!



Quote
pthompson
Thank you for sharing all of these steps.
Quote
Visnet
Shinyplastic,

The issue is after "try these settings in The brain"

It does not work for me and advisors...... Maybe it is dependend on the proxy configuration, or even the brand.
I for one am not an admin to change settings on the proxy server. That proxy server will allow me to pass with Java 6, not with 7. To be more precise, I have this proxy issue only with the Brain not with other Java applications. That said, the Brain is probably the only software with active connections to cloud servers for me I think.

Have a look at this post to see what I tried to get a work around for this. It will work with Java 7, but only after a few restarts - which tells me there seems to be some issue in the sequence of proxy handling in the software itself.

Ultimately we should expect software to be able to work with proxy as is, without work arounds. It is a bit hard to get attention for it.

Mr. Patrick shows exactly that - "thanks for sharing" (a work around)  but no step to "lets solve this"

Wim


Quote
pthompson
Wim,

A couple suggestions from our engineers on this:
  1. Make sure you have imported the certificates into the keystore according to the Connecting to SSL services instructions.
  2. Make sure any certificates have been imported into the correct keystore; you may have multiple JDKs.
  3. Check to see that the correct keystore is in use. It should be in your JDK, not your JRE. Make sure the system is picking up the correct JDK. Try 'echo 4. %JAVA_HOME%' (Windows) or 'echo $JAVA_HOME' (Linux), and compare it to the value shown in Administration >> System Information.
  4. Check if your Anti Virus tool has "SSL Scanning" blocking SSL/TLS, if it does, this feature should be disabled.
Quote
Visnet
Patrick,

I am using this installation on a portable PC, which I am using at home as well as in the office. If any certificates are needed, I guess with or without proxy, those will be the same? In that case all certificates are fine. working in my homenetwork - without proxy - on the laptop TheBrain is working without issue on Java 7.x

I cannot check on the antivirus settings from my end, as this is maintained with centralised company settings. I have asked our IT team to check. But as the installation from my laptop is working from my own house (no proxy enabled) I guess it is not blocking.
When the IT team comes back to me I can confirm, for now I expect the setting to be ok.

Did you take a fresh look at the work around? As this - to me - showing that TheBrain can work with proxy and Java 7.x, but is doing something in a wrong sequence at initiating it.

Wim









Quote
Visnet
Our IT has confirmed there is no blocking on SSL/TLS. They even checked it on my local machine with using TheBrain with Java 7, antivirus is not getting nervous at all, like it should :-)

Wim
Quote
XOver

Hi,

and once again I have to chime in here:

Shinyplastic:

Quote:
- verify it works not on a proxy [smile]  check
- instead of a .pac you need to find the IP / name of the proxy server and port check
- verify this works with ping check
- verify this works in a browser Firefox / Chrome check
- try these setting in The Brain fail

- if it works consider using Cntlm to tunnel all your programs to localhost: port
- then you can set / change all your programs with one .bat file (on / off the proxy network)

Cntlm is not an option on my machine.

While I love TheBrain, this problem has not been fixed for ages and renders the product mostly unusable for me.

So please don't let this fall under the table once more...

Slightly grumpy

XOver

Quote
pthompson
XOver,

Can you please specificy what exactly does and doesn't  happen in TheBrain? Any additional information you can share will help us troubleshoot this issue. You may also want to email support@thebrain.com with your output.log file. In Windows, right click the TheBrain icon in your start menu then select 'Run as administrator', this will enable TheBrain to run as administrator for one session. Next, reproduce the problem then email us a copy of your output.log file which can be found in Program Files (x86)\TheBrain or Program Files\TheBrain (if you are using TheBrain 64-bit). Please be sure to delete any existing output.log files before reproducing the issue so we can get a clearer look at what the issue may be. 
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software