TotalBalance
I'm using the most recent beta.

I've recently been getting sporadic error messages saying something to the effect there is possible corruption due either to hard drive failure or other system errors. The recommended solution is to restore from your most recent backup.

I've moved the entire database to a new hard drive, but still get the error msg. I've restored from backup, still get the error message.

What should I try next.

Quote
Harlan
Lars, please post your output.log file from the PB program files folder. Also, when are you getting the messages? Is it when you do a particular operation? It could simply be a bug in the code and not a true corruption.
Regards,
-Harlan
Quote
tcahill
Harlan wrote:
Lars, please post your output.log file from the PB program files folder. Also, when are you getting the messages? Is it when you do a particular operation? It could simply be a bug in the code and not a true corruption.


I am experiencing the same errors on two of the files I use regularly.

As I've just completely started over with a clean install of OpenSuse 11.0, I'm sure there are a few extra zingers in my config that will be clouding the issue here.

In my output file, you will see that I inadvertently clicked the PB icon twice, and so two instances tried to load the same file.
You will also see that the files are read-only. I've confirmed that there is a file-access issue on my end....

Having now straightened out the file permissions issue the data corruption error has gone away.



When loading 4.5.0.5, The errors appear on PB startup just after the tips screen loads, while the last-opened pb file is loaded. The error seems to display three or four times as the file opens. I attempted to brainzip the loaded file, and did so successfully, but opening that brainzip failed with error.

Be vewy quiet. I'm hunting wabbit.
Quote
TotalBalance
Hi Harlan,

As I recall, the error msg. often happens while I'm re-organizing thoughts (e.g. CTR-Click on multiple thoughts, remove links then link, add to to other links OR dragging URL from browser to link to thought).

Here's my log file:



Quote
Harlan
tcahill wrote:
Harlan wrote:
Lars, please post your output.log file from the PB program files folder. Also, when are you getting the messages? Is it when you do a particular operation? It could simply be a bug in the code and not a true corruption.


I am experiencing the same errors on two of the files I use regularly.

As I've just completely started over with a clean install of OpenSuse 11.0, I'm sure there are a few extra zingers in my config that will be clouding the issue here.

In my output file, you will see that I inadvertently clicked the PB icon twice, and so two instances tried to load the same file.
You will also see that the files are read-only. I've confirmed that there is a file-access issue on my end....

Having now straightened out the file permissions issue the data corruption error has gone away.



When loading 4.5.0.5, The errors appear on PB startup just after the tips screen loads, while the last-opened pb file is loaded. The error seems to display three or four times as the file opens. I attempted to brainzip the loaded file, and did so successfully, but opening that brainzip failed with error.



Hi Tim,

In your case, all of the errors appear to stem from the read-only status of the file system. We'll add a check for this condition so that it isn't misreported as another error. Thanks for posting.
Regards,
-Harlan
Quote
Harlan
TotalBalance wrote:
Hi Harlan,

As I recall, the error msg. often happens while I'm re-organizing thoughts (e.g. CTR-Click on multiple thoughts, remove links then link, add to to other links OR dragging URL from browser to link to thought).

Here's my log file:



Thanks for the info Lars. Unfortunately there was no relevant info in your log file as it is recreated each time PB is started. Next time you see the error, please grab the log file and post it. Plus, if you can note exactly what you were doing at the time, it would be very helpful.
Regards,
-Harlan
Quote
TotalBalance
Hi Harlan,

As it just happened again, here ya go ..

In this particular case, I was moving files from a virtual folder into my brain (highlighting all files and dragging them into the plex. The window popped up three separate times before it was over. The one constant seems to be moving thoughts and/or files.

I don't believe I restarted PB so the log file should show you what's needed.

Quote
Harlan
Great. Thanks Lars. There is no corruption problem in the logs you updated. Looks like a bug related to virtual thoughts. We'll get this fixed shortly.
Regards,
-Harlan
Quote
TotalBalance
Great. Glad to hear it looks like a bug vs. I have corrupted data
Quote
Harlan
These bugs have been fixed. Thank you for uploading your log file.
Regards,
-Harlan
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software