Cornan
In 5.5 / Vista, create a new thought with a single character name, in Normal View.

In the Properties tool panel, type something rapidly into the thought name.

The cursor will jump around in the thought name and some characters will be lost.

Happens consistently in 5.5.1.0b / Windows Vista Ultimate.

Does not happen in 5.0.4.0 / Windows Vista Ultimate.

(Reproduced after a reboot)

I'm almost wondering if the keyboard input is locked into a loop with changing the thought as rendered in the plex.

Quote
dyslucksia
Quote:
I'm almost wondering if the keyboard input is locked into a loop with changing the thought as rendered in the plex.


I couldn't duplicate the character loss problem on my Windows XP machine, but I'd say you're on the right track with your comment as there is a significant delay while PB struggles to update the Plex every time you type another character into the keyboard buffer. Anything which slows PB down even more might increase the delay and even confuse it.

Pasting rather than typing might be one workaround.
PB 5.5.2.1 on Windows XP, J-1.6.0_17
Quote
Cornan
Here's the result of typing the "The rain in Spain falls mainly on the plain", which is easy to type rapidly (I let the thought settle down for a couple of seconds after the "T" and then typed the rest rapidly):

The rain in Sinlainolain

I can also see the effect by holding down a letter key.  During the key repeat I can see the cursor jump back to the left several times.

This may well be a PersonalBrain / Vista only issue - I've had two other issues with PersonalBrain and Vista; one with Microsof Intellimouse drivers (mouse wheel only shrinks in Expanded View) and the other involves the PersonalBrain being "squashed" in relation to some taskbar activities.  Neither of these has been fixed (I switched to a Logitch mouse but the squashed screen is still a nuisance).

This problem, however, only affects version 5.5; I have both 5.5 and 5.0 installed on the same Vista machine.

My regular keyboard has a PS2 connector but I tried a USB keyboard, too.  It's not as deep as the hardware drivers, though it could well be another layer up in the driver structure in Vista.

This bug should be fixed as I don't want to t-y-p-e  s-l-o-w-l-y  a-l-l  t-h-e  t-i-m-e.

Quote
mbaas
Hi Cornan,

some german users had the problem as well and even Moe found it, so by now the engineers will at least know about it, or maybe they haven even fixed it already

Cheers

Michael 

Quote
tshanno
Cornan wrote:

This may well be a PersonalBrain / Vista only issue


I can consistently repeat this on my linux box.

Tom S.

PB 5.5.1.0-b J-1.6.0_0 under Ubuntu linux and Mac OSX Snow Leopard.
OSX & J-1.6.0_17
KUbuntu 9.10
PB 5.5.2.2
KDE 4.3.2 & J-1.6.0_16
Quote
Moe
We are aware of this issue and are currently looking into it.

Thanks,
Moe


Quote
pshanks
I've also noticed this with Vista too with the cursor jumping to the end of the thought name when typing and/or cutting and pasting.

I'm also finding the CTRL a thought, or CTRL a gate, can sometimes take forever to select a thought or thoughts. This has happen since 5509 and seems to happen after PB has been running for a bit.

Quote
Mike8Austin
Just to add the data point, I get this same behavior on Windows XP, and it is extremely consistent.
MikeA
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software