gbolzan

TheBrain 9.0 is incredibly faster than Thebrain 8.0 (and previous versions) when launching (even when Thebrain opens several brains at the same time). That is one of the reason why I do not bother too much when the program crashes (fortunately, I have never lost any data).

However, working in the plex area is notably slower than older versions of Thebrain (it is not only about resizing performance). For instance, if you type the name of a new thought very fast it is highly likely that a few letters “get lost on the way”. The same applies for creating thoughts (popup windows) and creating links (link lines work lower when you use the mouse than previous version of TheBrain). I know that this is a problem not easy to resolve.

I also noticed that sometimes a brain becomes slower to respond than others do. Maybe it is about the new database engine, I do not know. In this case, I can only point out the problem; I do not have more information or symptoms. All those brains are small (400 thoughts, more or less).

Having said that, I am still using TheBrain 9 (over 8.0) because of the new features and starting speed. I hope you can resolve the speed problem before the final release.

Thank you,
Gerardo

Quote
zenrain
I've noticed slowdown when I have Update displayed content on hover and Previews for file attachments enabled. This usually occurs on thoughts where a web page is displayed (vs notes). Usually it's as TheBrain 9 is trying to render the web page AND do something else (like activate a thought). 

When you have noticed TheBrain 9 slowing down, have you noticed a similar commonality? Or if it's not web pages, does it always occur when x happens (for example, during a sync, when you are activating a thought with a pdf or a lot of notes)?
macOS 10.14.6
TheBrain 11.0.119
Quote
gbolzan
I have noticed slowdown, for instance, when I am navigating or creating a thought and the program makes a pause or becomes slow. I close the program and start again, solved (not a great fix, but useful).

I think that some of the situations you mention have to do with the GUI performance. IMHO, it seems to me that the sources of slowness are two: GUI and database engine.
Quote
mcaton
Gerardo,

Can you please replicate the slowness again? Ideally when you are quickly typing a Thought name and a few letters are missed.  Once this happens, please post or send us a copy of your Output.log file.  This may help us identify if your Brain is performing other tasks or pinpoint the cause of the speed issues you've mentioned.

Thank you,
Matt
Quote
Harlan
Gerardo,

Are you on Windows or macOS? It should not be missing characters typed while creating thoughts. Do you see the same thing happening when typing in other places? (For example, in notes, search, or when renaming a thought.)
Regards,
-Harlan
Quote
gbolzan

In order to avoid rewriting a thought I usually try to type a little bit slower but sometimes I forget to do that and type very fast (specially short thoughts). I have tried to replicate the slowness and is very easy in my case.

I am using Win 8.1 x64 on an AMD FX6100, 16GB, 250 SSD, Asus M588A-M (video onboard: maybe if I had a better video card I would not have that video slowness). I tried to replicate the same action using Thebrain 8.0 (same system) and I could not do it, the software always responded OK. CPU is almost always at 20% or 30%, I mean, never full loaded.

The word I was trying to write in that moment (using Thebrain 9.0) was the Spanish word “Nuevo” (New) and the result was "vo" (the "nue" part was missing). I did not actually create the thought, I canceled the operation because it was only a replicate of the problem.

I think that this problem only happens when I am typing in the "thoughts box" (creating and editing thoughts) but not when I do a search. In the case of the notes, it happened to me once, but it was different: I was writing a note a litlle bit long and, suddenly, the note desappeared completly and I could not recover it by using the UNDO command (It was like I had pressed something like "CTRL+A" and overwrite the whole note but it wasn't the case, I think).

I note that the whole GUI is a little slow -including the notes editor- and if you work fast you can make mistakes without having control over what you are doing.

*******************************

2017-03-09 00:08:10.8382 | DEBUG | TheBrain.Client.NotesContentController | [302] AttachmentSource set to (1793-05-31 al 2 junio) Levantamiento Popular sans culotte notesEditorWebView.IsEditorReady True

2017-03-09 00:08:16.9846 | DEBUG | TheBrain.Core.BrainLogic | [4754] TokenSearch 'vo' Term #0: vo. totalGuids: 3 @ 6

2017-03-09 00:08:16.9846 | DEBUG | TheBrain.Core.BrainLogic | [4760] TokenSearch 'vo' got all Guids @ 7.

2017-03-09 00:08:16.9846 | DEBUG | TheBrain.Core.BrainLogic | [4764] TokenSearch 'vo' got Thoughts @ 9.

2017-03-09 00:08:16.9896 | DEBUG | TheBrain.Core.BrainLogic | [4768] TokenSearch 'vo' got Links @ 11.

2017-03-09 00:08:16.9896 | DEBUG | TheBrain.Core.BrainLogic | [4941] SortAndFilterMatches 'vo' checkpoint 6 @ 2

2017-03-09 00:08:16.9896 | DEBUG | TheBrain.Core.BrainLogic | [4775] TokenSearch 'vo' sorted 3 matches in 20 from 3 tokens.

2017-03-09 00:08:16.9896 | DEBUG | TheBrain.Desktop.Controls.SearchBox | [267] DoDatabaseSearch 'vo' got results in 62

2017-03-09 00:08:16.9896 | DEBUG | TheBrain.Desktop.Controls.SearchBox | [274] DoDatabaseSearch 'vo' disambiguated in 65

2017-03-09 00:08:17.0066 | DEBUG | TheBrain.Desktop.Controls.SearchBox | [276] DoDatabaseSearch 'vo' converted in 68 - Finished

2017-03-09 00:08:17.0066 | DEBUG | TheBrain.Desktop.PopupDialog | [128] Disposing PopupDialog: PopupDialog

2017-03-09 00:08:21.5268 | DEBUG | TheBrain.Desktop.PopupDialog | [128] Disposing PopupDialog: #lJv

2017-03-09 00:08:22.8876 | DEBUG | TheBrain.Core.BrainLogic | [4754] TokenSearch 'nuevo' Term #0: nuevo. totalGuids: 3 @ 2

2017-03-09 00:08:22.8876 | DEBUG | TheBrain.Core.BrainLogic | [4760] TokenSearch 'nuevo' got all Guids @ 3.

2017-03-09 00:08:22.8876 | DEBUG | TheBrain.Core.BrainLogic | [4764] TokenSearch 'nuevo' got Thoughts @ 6.

2017-03-09 00:08:22.8876 | DEBUG | TheBrain.Core.BrainLogic | [4768] TokenSearch 'nuevo' got Links @ 7.

2017-03-09 00:08:22.8876 | DEBUG | TheBrain.Core.BrainLogic | [4941] SortAndFilterMatches 'nuevo' checkpoint 6 @ 0

2017-03-09 00:08:22.8876 | DEBUG | TheBrain.Core.BrainLogic | [4775] TokenSearch 'nuevo' sorted 3 matches in 8 from 3 tokens.

2017-03-09 00:08:22.8956 | DEBUG | TheBrain.Desktop.Controls.SearchBox | [267] DoDatabaseSearch 'nuevo' got results in 17

2017-03-09 00:08:22.8956 | DEBUG | TheBrain.Desktop.Controls.SearchBox | [274] DoDatabaseSearch 'nuevo' disambiguated in 18

2017-03-09 00:08:22.8956 | DEBUG | TheBrain.Desktop.Controls.SearchBox | [276] DoDatabaseSearch 'nuevo' converted in 19 - Finished

2017-03-09 00:08:22.8956 | DEBUG | TheBrain.Desktop.PopupDialog | [128] Disposing PopupDialog: PopupDialog

2017-03-09 00:08:30.6042 | DEBUG | TheBrain.Desktop.PopupDialog | [128] Disposing PopupDialog: #lJv

2017-03-09 00:08:30.6172 | DEBUG | TheBrain.Core.BrainTransaction | [61] Rolling back

2017-03-09 00:08:30.6368 | DEBUG | TheBrain.Desktop.PopupDialog | [128] Disposing PopupDialog: CreateThoughtDialog

**************************

Quote
Harlan
1. How are you initiating the thought creation? (mouse drag/menu item/keyboard shortcut) Is it possible you started typing before the thought creation dialog box was fully displayed?

2. In the example you gave, the missing characters are at the start of the text. Is this always the case or have you had it miss characters in the middle of the text you are typing?

3. With regard to notes, most cases of a problem like you describe happen when text is entered on a different thought than was originally perceived... Also, we have fixed many bugs related to notes - when did the disappearance happen and can you replicate it? 

4. Please try going to preferences and disabling (unchecking) the following options: Update displayed content on hover, Embedded browser for web links. Once you have disabled these options, see if you can still recreate the problem.
Regards,
-Harlan
Quote
gbolzan

Hi Harlan,

1) I usually use F6 to create thoughts and F2 to edit them (that is, i use keyboard)

2) You are probably right: the popup window appears after I started writing and there I experience the slowness. I did the same in the case of Thebrain 8.0 but there is no delay at all (or maybe there is some kind of  buffer that fill the gap)


3) In the case of the note, it happened with the same thought I was focused on. I cannot replicate the problem because it happened so fast (the error) that I do not know what happened and what is really strange is that I could not recover the note by using the Undo command.


4) I will try to recreate the problem with those options off. Anyway, when I replicated the error the last time (with the word “Nuevo”) the notes panel was hidden, I mean, the plex was in “full screen mode”, so to speak (neither “hover” nor “embedding browser” were active at that time)


Thank you,

Gerardo

Quote
Harlan
Thanks for the info. There is an animation that displays when the create thought dialog is opened. I believe you are typing during the animation and that is leading to the input being missed. We will add a preference so that this animation can be disabled, which should eliminate this problem.
Regards,
-Harlan
Quote
gbolzan
Thank you Harlan. I will let you know if I experience more problems about slowness.
Gerardo
Quote
gbolzan

Hi Harlan, I have just deactivated the “hover” and “embedded browser” options and nothing has changed: I can still reproduce the problem.

I know that the probable cause is the animation you mentioned yesterday. I just wanted to give that configuration a try.

Thank you,

Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software