jotapa
TheBrain 9.0.94 does not start.

I am getting the dreadful Windows 10 message: "TheBrain has stopped working" when I try to start the program.

Debugging attempts:

- Uninstalled and reinstalled the TB after restarting the PC but the problem persists.

- Moved the brains folder to a new folder - in case there was a corrupted brain file and it didn't work.

- Disconnected from the network to prevent the connection to Webbrain or whatever v9 connects to (the preview cloud service), but the problem is still here.

Don't know where to collect the Error log...

What changed in my PC since I last ran the program a couple of days ago? Windows 10 upgraded to a new Insider version - in fact two: releases 14366 and 14367. Can't think of anything else. Not sure if it is related or just a coincidence.

Everything else is working. Only TB is having problems.

Can you please help?

Thanks,
Joao

Quote
mcaton
Was 9.0.94 the version that was running for you prior to the Win 10 upgrade?  Sounds like you have, but have you reviewed the troublshooting steps on http://www.thebrain.com/products/thebrain/thebrain9/update-troubleshooting.

Other than that, the key component that stands out to me is the "insider version" you mentioned. We won't be able to support v9 on anything other than the public release version of Windows 10 (and earlier versions).

Thanks,
Matt
Quote
jotapa
Yes, I was running 9.0.94 since it came out and I uninstalled/reinstalled the software (several times) when I started having problems. 

I understand what you are saying about only supporting the public version but the upgrades I am getting through the Windows 10 Insider Program are basically the update that will be downloaded by everyone in just a few weeks. Have you tested that yourselves TB team? 

Is there any log I can take a look at or send to you?


Quote
mcaton
Not sure if the logs would have captured anything yet, but their located in:

C:\Users\[user name]\AppData\Local\TheBrain\Logs

And we're happy to take a look.

Thanks,
Matt
Quote
jotapa
Log files attached. Hope you can help.

Quote
mcaton
Thanks for the logs - they turned out to be particularly helpful.  

At this point, we're thinking that the fact that the problem happened after the Windows 10 upgrade may have been coincidence. The root of the problem is that there are two specific records in your TheBrainMeta.db file when there should only be one.  When the record is called for - the app is then getting confused on which item to read.

Can you please upload your C:/users/[user name]/AppData/Local/TheBrain/MetaDB/TheBrainMeta.db file to us at http://www.hightail.com/u/TheBrain (this is our secure file upload page).  Just reference this thread in the  message and we should be able to repair the file and return it back to you.

*important* - don't delete or attempt to edit this file on your own!  Just send us a copy.  Any alterations to this file could result in losing access to all your existing Brains.

Please let me know if you have any further questions.

Thanks,
Matt
Quote
jotapa
Done!

Looking forward to hearing from you.

Joao
Quote
mcaton
Joao,

Thanks for the upload.  I have received the file and placed this in the engineering queue.

Thank you,
Matt
Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software