grahamrhind

Using 5.5.2.4 on Windows XP:  When I insert an image into a note, the image is pasted with a local URL (file:///C:/Documents and Settings ... etc.),.  I carefully change all of these to a web address in the image properties Image URL field (http://www.grcdi.nl/ ... etc.), and the image is then read from the Internet.  However, when I leave the note the URL springs back to the local version - the web URL is not sticky.

Seems like a bug to me - or can this be overridden? It's a real problem for those of us creating web sites from The Brain as users cannot view the images. 

Thanks


Quote
grahamrhind
Additional information on the above: when the brain is exported to a site brain the URL is translated to a relative online URL, so the users can see the image.  However, when I want to change the image I need to change it in every single note rather than uploading one altered image to one location, which can be read by all notes from the new location. Not ideal!  Why won't The Brain accept a real URL rather than a relative one for images?
Quote
Moe
Grahmam, Try using the Insert > Insert Image... command in Notes. You can paste the URL directly into the address field. This will save you time from pasting the image into Notes then editing Image Properties > Image URL field. 

Thanks,
Moe
Quote
grahamrhind

Thanks Moe.  However, your suggestion gives exactly the same problem.  Let me show you. 

Attachment tb1.png is inserting the picture.  You see that I am adding an http:// url:

When I have finished, I right-click, choose Image Properties, and you can see (tb2.png) that the http:// url has changed to a local file:/// url.

I have found a way around this, and that is to paste html into the html view of the note rather than adding the image to the design view.  This maintains the http:// url, but is really not a useful way of working (tb3.png)

I think that this is errant behaviour - it would be useful if it were corrected, or a switch added to turn it off!

Thanks






Click image for larger version - Name: tb1.png, Views: 67, Size: 26.25 KB Click image for larger version - Name: tb2.png, Views: 68, Size: 5.74 KB
Click image for larger version - Name: tb3.png, Views: 67, Size: 5.71 KB
Quote
Moe
Graham, Make sure you don't have the option "Save images from the Internet locally" enabled in Options > Preferences > General (tab). If you don't have this option enabled PB will not change the Image URL to a local URL.

Thanks,
Moe


Quote
grahamrhind

Thanks Moe - exactly what I was looking for.

Note: I'm pretty sure this was working correctly in an earlier version, as I checked this behaviour when I started creating this database, and that this switch was changed by one or other update, so it would be useful if that weren't to happen in future updates (if, indeed, that's what happened)

Cheers!



Quote

Newsletter Signup  Newsletter        Visit TheBrain Blog   Blog       Follow us on Twitter   Twitter       Like Us on Facebook   Facebook         Watch Us on Youtube  YouTube       

TheBrain Mind Map & Mindmapping Software     Download TheBrain Mind Mapping Software